WD Black SN750 500GB Not Recognized

I just purchased a new WD SN750, installed it on my pc, and nothing will recognize. I’ve rebooted multiple times, even updated my motherboard BIOS twice to verify that was not the issue(One update offered additional NVMe and SSD support; the other update was the most recent BIOS version). I cannot see the disk in any Windows software (Disk Manager or Device Manager) or in the WD dashboard. I have not yet tried this on another pc, but I will have an opportunity to do that in a few days. Any help would be appreciated. My system is as follows:

Windows 8 Enterprise
Gigabyte GA-97x-SLI motherboard (software v. F10b, 3/3/16))

I believe all drivers are up-to-date, and as I mentioned the BIOS has already been updated to the latest version.

Dear Vrazoc

Have you try to remove your windows drive and then run only NVMe SSD…?

Regards

Banu

No I have not, thank you for the suggestion. I will attempt this in the next day or two when I get the chance and post an update afterward.

Ryan

If you get a new SSD and it won’t show up in the Windows Explorer, it’s likely in the “uninitialized” state.

If so, for Windows 10/8 users:

  1. Press “Win + R”, type diskmgmt.msc. and click “OK” to open the Disk Management tool.
  2. Find the HDD or SSD that you need to initialize and right-click on it, and select “Initialize Disk”.
  3. In the Initialize Disk dialog box, select the correct disk to initialize. And then click “OK” to accept the default partition style, or you can change the partition style (GPT or MBR) as you want.

Banu, thanks for that suggestion, my motherboard has recognized the drive and I can see it in my boot options in the BIOS menu.

I think I read this elsewhere… If I install Windows OS on the NVMe drive, will that make sure my pc continues to recognize the drive after I boot up??

And thanks, Cosara, the drive is not showing up in Disk Manager after I boot up Windows. The only way I’ve been able to see it is in the BIOS menu, as a drive to boot from.

Ryan

SSD showing in BIOS, but NOT in Device Manager and NOT in Disk Management.

Try this one:

  1. Open Device Manager
  2. Click on IDE ATA/ATAPI controllers
  3. Right click on Standard SATA AHCI-Controllers, select Uninstall
  4. Reboot, after reboot drive shows up in Device Manager (I hope so)

Thank you for the continuing suggestions, Cosara, I will have to try that, but I’m not sure the SATA AHCI controllers would handle this drive at all. The SSD I have connected is an NVMe SSD connected to the M.2 PCIe interface. Wouldn’t another driver interact with this SSD? Like possibly a PCIe driver/controller?

That’s possible.
Question is, do you have an IDE ATA/ATAPI-controler installed or not?

I did have the IDE ATA/ATAPI controller installed like you indicated. And after uninstalling and rebooting, I still don’t see the drive in Disk Management or using the Western Digital Dashboard.

Something I do see that I believe is new in the past two days, is that I have a unknown PCI Device listed under “Other devices” in device manager. I’ve tried updating the driver for it by using windows built in search feature, but that has not found anything in my multiple attempts. I’ll have to try physically removing the drive removes this unknown PCI device. But even if I do figure out that’s my SSD, it doesn’t look promising that Windows will find a driver for it.

Something went wrong during installation.
Remove the SSD physically, reboot computer and install the SSD again.

Which storage controllers are listed in Device Manager?

Something like this:
Inter® Chipset SATA/PCIe RST Premium Controller
Standard NVMExpress Controller

Do you have an other disk manager available, like EaseUs Partition Master?

Cosara and Banu, I appreciate the help on this. I went ahead and installed Windows 10 (clean install) on the new WD SN750, since it was recognized by my BIOS. I’ve set my WD SN750 as the primary boot drive, have restarted my pc multiple times, and have not seen any issues at all using the drive since my install of Win10.

Note that I followed guidance here to install Win10:

Microsoft Help Win10 Install

All in all, it looks like the SSD now functions correctly, Windows recognizes it, and I have a fresh OS install to boot (pun intended). I hope this helps anyone with a similar issue.

Vrazoc