WD_Black SN850 not detected by BIOS on bootup from power-off

Hi, I just got a new wd_black SN850 2TB drive. I have Windows 10 installed and almost everything seems to be working normally. The problem is when I turn my PC on from power-off, it boots straight to BIOS, which reports no M.2 drives detected. When I exit BIOS and reboot, it is detected again and boots into Windows normally. This happens every time the PC is booted up from power-off. What is going on here, and is there any way to fix it? My motherboard is an MSI X570 Gaming Plus.

Maybe, just a guess, boot priority needs to be set to the SN850 in BIOS???

Boot priority has nothing to do with the issue. The drive is completely not detected by the BIOS on cold boot up.

Maybe the M.2 port is shared with a SATA port being used by a HDD?

Nope, no other M2 or SATA devices are connected. Again, the problem is the drive is not detected by the BIOS, it’s not a configuration problem. Maybe the drive takes longer to “boot up” than the BIOS does, so it is not ready when the BIOS initializes is my guess. Maybe it needs a firmware update? This drive is so new maybe other people will have this problem too once others start getting it.

There is a firmware bug in version 611100WD which seemed to be solved in 611110WD.

But it is not released yet to the public.

See this dutch article:

1 Like

Thanks for the link. I didn’t see in the article any mention of the drive not being detected on power-on, they seemed to be talking about problems with stress testing the drive. I did contact WD support and they said they were researching the issue.

Yeah this sounds more like a motherboard BIOS issues actually.

I have the same issue: First power on–> Pc jumps straight into BIOS where I can not see the SN850. After leaving and restarting it is visible.

MSI MPG X570 Gaming Edge Wifi || Ryzen 3800x || Gainward RTX2080TI || 2x16 Gb Crucial Ballistix RGB 3200@3800 || XPG Core Reactor 850 Watt Netzteil || Crucial P1 1 TB NVME SSD System || WD SN850 1TB NVME || 2 x 500 GB Crucial MX300 SATA SSD || 2 x HDD 3TB

Ah very interesting that you also have an MSI X570. I would not be surprised if that was the problem. There are newer bios versions available for my board but they cause instability and other problems so I am still using a bios from January 2020.

Yep, and guess what: With the newer Bioses I get instabilities too. But I if you read about the problems with the 5000x series I think that AMD messed up the AGESA Code. But I agree, that the MSI Bios policy is not good.

Slowly I regret that I switched from Intel to AMD

After further tests I came to the conclusion, that the Problem appears only on M2_1 Slot (PCIe 4)
when I do a cold boot.

If the SSD is installed in M2_2 (PCIe 3) it is always present in BIOS; also @ cold boot.

The M2_1 slot ist ok, because my crucial P1 is also detected @ every boot.

So I think this is a SN850 firmware problem or a MSI Bios problem.
Smart tests in the WD software ended with no error.

1 Like

Thanks for doing that testing. I’ll forward your results to the tech support ticket guy.

Also opened a ticket. But the service is a drama. You get stupid copy paste answers not even answering your question. After the third stupid answer I asked to redirect me to next level support.

If nobody is interested at WD in resolving the problem I will simply RMA the SSD.

Worst online support ever!

I did not have that problem, it seems my support ticket went straight to an engineer that asked for a bunch of logs and data and said they are looking into it. And the problem could well be on MSI’s side so I wouldn’t be too quick to judge.

Yep you are right, but this is a joke:

Incident Details
Reference #: 201220-001334
Category: Troubleshooting
Subject: SN 850 not detected in UEFI @ cold boot
Product: WD_BLACK SN850 NVMe SSD

Response by Email Pooja VK
(12/26/2020 01:14 PM)

Hi Martin,

Thank you for contacting Western Digital Customer Service and Support. My name is Pooja KV.

It is my pleasure assisting you with your case and here is the case number for any future references: 201220-001334

As per the email received, I understand that the drive is not detecting, I apologize for the inconvenience.

Please refer to the following article for further troubleshooting steps:
Title: How to physically install, set jumper settings, and set up a Serial ATA, EIDE, or SSD drive in Windows
Link: https://support-en.wd.com/app/answers/detail/a_id/1991

Title: Downloading WD SSD Dashboard to know the drive health
Link: https://support-en.wd.com/app/answers/detail/a_id/23377

If you experience any issues further or require any type of assistance, please feel free to reply to this email.

You can also contact us through Live Chat support by clicking on this link (https://support-en.wd.com/app/chat/chat_launch).

Thank you for choosing Western Digital Support. Have a nice day.

Thanks & Regards,
Pooja KV
Western Digital Technical Support
https://support-en.wd.com

Customer by Service Web Martin Winkler
(12/22/2020 11:01 PM)

Didn’t get any constructive input from you.

SN850 isn’t recognized on M2_1 slot (pcie 4x4) @ cold boot. Jumps straight into Bios. After exiting Bios and restarting the drive shows up in Bios.
No problem on this slot with my crucial P1.

Also no problem with the SN850 on M2_2 (pcie 3x4).
Works flawless there and is recognized @ first boot.

So please return constructive input and not copy paste answers.

Thank you!

Response by Email Syed M
(12/22/2020 10:16 AM)

Dear Customer,

Thank you for contacting Western Digital Customer Service and Support. My name is Syed.

It was a pleasure assisting you today. If you experience any further issue or require any type of assistance, please feel free to reply to this email.

Please opt-in to receive our 30 second support survey using the link below:

If you have any further questions, please reply to this email and we will be happy to assist you further.

You can also contact us through Live Chat support by clicking on this link (https://support-in.wd.com/app/chat/chat_launch). Our working hours are from 9 AM to 6 PM (Mon - Sat).

Sincerely,
Syed
Western Digital Service and Support
1800-120-5899 / 1800-419-5592
https://support-in.wd.com

In order to process your email, please do not remove this Reference # 201220-001334

Auto-Response by Administrator
(12/20/2020 12:16 PM)

The following answers might help you immediately. (Answers open in a separate window.)
Answer Link: How to detect WD_BLACK AN1500 NVMe SSD ADD-IN-CARD as a boot drive
Answer Link: How to configure WD_BLACK AN1500 NVMe SSD ADD-IN-CARD as a boot drive for new OS install and existing OS.
Answer Link: Error: “DISK I/O ERROR”, “INVALID SYSTEM DISK”, or “NO OS FOUND” while trying to boot your Windows computer
Answer Link: How to clone existing boot drive to WD_BLACK AN1500 NVMe SSD ADD-IN-CARD
Answer Link: Problems booting a PC with an external USB drive connected

Customer by Service Web Martin Winkler
(12/20/2020 12:16 PM)

Description see here:

Thanks for your help!

Cheers,
Martin

Got the same issue with the SN850 1TB drive. Have one SN850 500GB drive for OS and another SN850 1TB for games and other data. I’m using the ASUS TUF GAMING X570 Pro motherboard. When the PC has been turned off longer then a minute and turn it on the SN850 1TB drive is not detected in BIOS and Windows. I need to reboot and it’s available again. Tried the new firmware update but it didn’t help. The SN850 500GB works as expected on M2_1 Slot (PCIe 4) the SN850 1TB is on M2_2 Slot (PCIe 4). I also have no other SATA drivers attached and tried all kinds of bios settings but to no avail.

Did you get a solution from WD yet? I did not hear a single constructive advice and there are more cases than ours. Also on other MB’s. Another user on this support board has the problem, that the drive disapears when waking the pc up from sleep!

So I am pretty sure that the problem is the WD Firmware and the energy management.

No I haven’t received any updates yet.

Has anyone heard back on this front yet? I’ve also opened a case with support.

My motherboard (MSI MEG x570 Unify) has three NVMe slots - I’ve tried all of them, connected to the CPU or PCH lines, and the problem persists for me.

Have also tried setting “gameing mode” on to hopefully disable some of the power management in the drive, but that hasn’t solved the issue either.

It appears that I’m also unable to upgrade my firmware beyond 611100WD.

I don’t have this issue with a Samsung 970 Evo drive, or a Samsung 980 Pro. That said, I’d prefer to use this WD SN850 for the speed / capacity it offers if we can figure out a way to solve the instability. =)