WD 2 GO can't access remotely

Hi all,

I’m having problem with my WD 2 GO to connect to MyBook Live remotely. It’s working fine within LAN but not external(home or mobile network).

Please help to assist me what else I can do for this case. Attached are some screenshots from my mobile and MyBook Live configuration.

SC20110927-083807.png

Network.JPG

Remote Access.JPG

Best regards,

Steven Lee

Maybe you should try contacting WD’s Technical Support about this. You can do so either by phone or email.

To Contact WD for Technical Support
http://support.wdc.com/contact/index.asp?lang=en

Thanks for reply.

I did email Technical Support regarding this issue. However, the reason that I post here is to get more user experience.

I did try to change the network mode to DHCP, but it doesn’t help at all. By the way, I’m using FortiGate-_80c_.

One option I would suggest if it is available on your Router settings i.e. enabling UPNP which will provide direct access to the My Book Live and communication speed will be faster than relay. By the way what is the Router being used. I would suggest contacting WD technical support through phone call so we can investiagte the issue right away

Thanks for your reply. However, WD Tech Support is very slow in response.

Is there any way I can get more information? What OSI layer WD MyBook Live in? Will it be compatible with Layer 3 router?

Besides that, how to configure the port and enable uPnP in the WD MyBook Live? As I saw there are the setting in MyBook World instead of MyBook Live.

Enabling UPNP needs to done on your Router configuration.  I would still suggest you calling WD support and we can arrange appropriate engineer right away to look into the problem