Very slow transfer on My Passport for Mac

I just purchased this 1 TB My Passport for Mac.  My iMac (4 years old with USB 2 ports) recognizes the drive and lets me select it.  I trying doing a 600 GB Time Machine backup on it and it gets about 50 GB in and then starts to crawl for data transfer.  It literally starts transfering at KB per minute. The “time remaining” window goes to over 200,000 days!!

I thought it might be Time Machine so I tried to copy my Aperature library directly to the drive using Finder.  Again it stars out fine coying the first 1 GB in less than a minute.  But then when it hits 1.05 GB transfer it slows to a crawl again.  I tried the same copy twice with the same outcome.  First bit moves at expected speeds and then it slows to a crawl.

It appears many people have some variation of this problem but I have not seen a solution posted.  It must be a common problem with a staighforward solution  PLEASE HELP!  I am extremely frustrated.  Of course I am running out of time.  I have to move my iMac overseas and I want to back it up first. 


To make sure that is not a drive issue, you can try testing the drive using Disk utilities.

Check the links below

How to access Disk Utility on a Mac computer

If it is a 3.0 drive, change the cable for a Micro 2.0 as some Macs will have problems with using legacy drivers for 3.0 devices on 2.0 ports.