3TB Passport very slow

Drag and drop takes forever. Example 61.2MB file 25 minutes. 5.45GB file 2 days. I have wiped the drive and reformatted it twice. Initially when first having this problem Disk Utility and Drive Genius could not mount drive to reformat it until I verified the drive once then I repartitioned it. Why is this drive so slow. I have 2, 2TB drives hooked to the same hub and they accept files and a pretty brisk rate. I can drop a 10GB file in a matter of minutes not days.

Is this just a bad drive? Got it last “Black Friday” so far not a good deal at all.

Hello, have you tried connecting the Passport directly to the Mac? If you are not using a powered USB Hub, it might cause for the Passport to not receive enough energy to work correctly. You can also try using DIsk Utility to run a test. Check the link below for the steps. 

How to test a drive for defects or problems on a Mac

Yes I did. I think this last partitioning did the trick as uploads to the drive are not that bad now.

Yes, my hub is powered. The 2, 2TB drives are also on the hub and continue to work just fine.

You know when it says, when it rains, it pours? Well my Samsung T240 monitor just  goes to black, will not stay on although the light still does. Probably a capasitor problem, just another headache to deal with. I know it is the monitor and not the computer as I swapped in my Samsung TV and it works with my mac mini just fine.

Well, i thought reformatting would fix this but once again a 1.17GB file takes 4 hours to transfer. This si not right. I tested it with a new cord. Placement in another usb slot but nothing works to correct the drive. If I try to run a repair utility, sometime the drive will not unmount but mostly it just fails to repair the drive. Help.

Hi, since the Disk Utility is unable to repair the Passport, it would appear to be faulty. You can follow the link below for the steps to replace it, you can also contact support directly and create the RMA for you.

How to get an RMA, (Return Merchandise Authorization) or replace a defective product under warranty


Unfortunately i think it is out of warranty. I tried splitting the drive into two partitions. Still having the same problem as well as on the second partition I am getting a failure notice that says “unused node 23042 not eraced and unused node 23171 not eraced”. It seems I have a few bad sections in the drive that is causing some problems. so, I assume it is time to junk the drive and buy another. Unless one knows how to fix or ingore those portions of the drive?