Extremely slow transfer, brand-new MyPassport Ultra

Hi, I have a brand new 1TB MyPassport Ultra which I configured for Mac. Received it yesterday. It’s meant to be used as a simple backup of my laptop using Time Machine, but I have yet to complete a backup due to extremely slow transfer speeds, <100 kb/s.

I tried using a different USB cable- no change. I tried using the other USB port on my laptop- no change.

I downloaded WD Drive Utilities and ran the Quick and Complete Drive Tests- it passed both.

What should I try next? Or did I just get a faulty product? How easy is it to return (I bought it on Amazon)? I’m pretty pissed off right now tbh, all this trouble is not worth what I paid for the drive.

Hello, wagnermr,

Well you are using time machine to make backup of the data from the Mac so the data on the Mac is in the form of clusters and the rate of transfer of the per files as compared to the single big files is much slower, so I would recommend you manually transfer the single big file to the drive and check whether it is transferring at a slow speed or at a high speed and if you see the transfer speed is slow then I would recommend you to should try contacting WD’s Technical Support about this.

To Contact WD for Technical Support