Very sad Mybook live user .....:-(

Heres hoping some kind person out there can help.

I’ve had a Mybook live for over 12 months and its been fine… until today.
Switch on my Win7  PC, Virgin Superhub, and Mybook Live (as I have done for last 12 months) to find that my network shortcut to my book live shows "windows cannot access NASdrive (what i’ve called my Book)

I’ve tried direct access through Firefox/ie9/chrome etc via IP address to be met with ‘The connection was reset’

WD Link shows the drive with correct IP address but will not allow Drive mapping, or configuration (same error message - ‘Connection reset’)

Dashboard - same problem and error message

Rebooted evrything several times - no change

Checked router settings.

Now heres the strange thing - Twonky seems to work fine !!!


I’ve not done a reset, as I have important data on drive that I do not want to lose.

As Twonky works, is there any waay I can copy my precious photos from ybook live to another drive?

Is there anyway I can fix my prob.

I have not undertaken any firmware update

I’ve tried connecting Mybook direct to PC - same problem

I’ve tried FTP to Mybook - connection refused

I’m now clutching at straws as I really dont want to get into realms of  RMA to WD, and as I’ve said, I really need some photos off this drive.

Please, any help advice, would be fantastic.


I can now access MyBook using a program called Nekodrive and mounting it as Linux NFS drive, so have been able to retrieve my important files, but get strange ‘lack of resources message’ when trying to write to drive.

I still can’t access drive from Dasboard, or from within Explorer so am looking for answer to this problem.

Thank you to WD User support for mailing me, but i’m in U.K. so 1-800 phone numbers dont work.

Please check your PM