Utterly fed up, drive broke after update and can't log a ticket! Last time I buy WD


New here and probably last time as well.

So, I have a my cloud drive (3TB) purchased a couple of months back.

Updated to the latest firmware after being prompted. The version i have updated to is - 04.04.01-112. I followed the process as per instruction and the drive got to “Reboot - Firmware update successful - Device is rebooting” screen. When the drive rebooted it now stays on a constant high speed, is very noisy (like it will take off!) and is constantly flashing a blue led that won’t stop. The drive was not unplugged during update and appeared to go well. The drive now whirs at very high speed and gets very warm. I have tried a restart, reset (press and hold for soft and hard) and nothing works. I cannot access the drive from mac, windows or tablet. The drive is also not showing on my home network as i have checked the routers device list.

Tried to log a support ticket and refusing to accept the S/N number. I have checked, double checked and triple checked and is correct. No idea what ti do or where to go now.

I remember years ago i had a “my book live” and an update broke the led light on the front and stopped working. I should have really learnt my lesson as to buy WD!

So, community - before I bin this drive any ideas?

Thanks in advance.

Try a 4 second reset by pressing in the reset button on the back of the My Cloud for 4 seconds. If that doesn’t work then try a 40 second System Restore by holding in the reset button for 40 seconds.

More on how to reset or restore a My Cloud device:

How to reset a My Cloud device

How to restore a My Cloud Storage device to factory default settings

The support thing; try photographing the serial number label on the base of the device, and send that to them. It won’t be the first drive broken by a firmware update.