After upgrade firmware my WD cloud dont work

The firmware was upgraded at night with reports succefuly. But i domt see my wd cloud. PC or home cinema and my router dont see WD . I tried restart but nothing. Last night I watched movie from my WD. Pls hepl me. Thanks
My WD has P /N WDBCTL003XXXX-10 and download version firmware 4.05. It is OK ? I was automatic upgrade firmware.

@candrej29 From reading your topic you should have firmware 02.xx.xx. See the following for more information and User Manuals. This is shown in the link for the User Manual, [
(P/N: WDBCTLxxxxxxx- 10 , FW 02.xx.xx)].

Hi . Thank for informations, I read this manual all day.
I tried 4 second reset and 40 second reset. Noting change
Pls i have a question,
I turn off my WD ,disconnect from electricity press hold button 40 second.(page 91 manual)
But i found the another proceure.

  • Power down the device and remove the power cord from the device
  • Using a paperclip or narrow tipped pen, press and hold the reset button
  • While continuing to hold the reset button, reconnect the power cord to the device and continue to hold the reset button for at least 40 seconds
  • After releasing the reset button the device will reboot
    Which procedure is OK?
    Morning i deleted all message about upgrade firmware. Can i restore them?
    My WD cloud flasing blue, net connection flashing green but i dont see it

Pls any help? My cloud is dead… 29.9 my cloud downloaded (automatically) bad version firmware (4.0 the right version is 2.0) and “succefully” instaled. How was that possible?
What now? PLS help me

More information is need. What My My Cloud model do you have? If you have a single bay/single drive My Cloud what version, first gen v4.x or second gen v2.x? You cannot upgrade a first gen v4.x to a v2.x nor can you downgrade a v2.x to v4.x.

Hi. I have this WD

my P/N: WDBCTLxxxxxxx-10.
It have firmware version 2.x. But automatically upgrade installed version 4.x
The problem is, I do not see the cloud from any device.
The blue diode flashes but nothing happens.
How to change firmware from version 4.x to 2.x?
Need more information?

@candrej29 Do you have a Windows PC and if yes, what OS, Windows 10? What are the rear LEDs on the My Cloud doing if anything? Are you able to open up the Dashboard? If yes, what is showing for your firmware and if you click on the arrow link what does it show for your firmware. See example image below. Click on, tap or activate image to view a improved image.


Did you read Bennor’s post?

Hi. Yes i have PC with WIN 10. My cloud is plugged into a router. I tried to change net cabel, diferent port in router, nothing.
Rear leds: the lower led lights on green , the upper led flashes green.
And no, i dont open dashbord i dont see from any computer, notebook, home cinema my WD. I took it to the neighbor, plugged into the router and again the device was not detected.
How can I upload the correct firmware?
Yes i read Bennot post. By mistake I answered your question.
I did not upgrade anything, the automatic upgrade downloaded version 4.x and installed it
I tried to log in through mycloud and could not connect
I turn off all firewall and the result - nothing.

@candrej29 Because the rear LEDs are working correctly have you rebooted your router? What router do you have? After rebooting your router reboot your PC and see if your My Cloud shows.

If not, then check the following.

I have ASUS RT-N12+. It was my first step, i restarted my router. Then i tried all action.
Thanks for instruction. I tried it but nothing hapend.

How do you know your v2.x firmware My Cloud upgraded to v4.x? V4.x IS NOT newer than v2.x firmware. The v4.x firmware is used on OLDER first generation single bay My Cloud P/N that ends with “-00”. Generally you cannot manually flash the v4.x firmware to v2.x My Clouds. One typically receives an error when they attempt to perform the flash and the user is returned to the My Cloud Dashboard.

I think there are a few other threads here that discuss the single bay second generation My Cloud stopped functioning after the very latest firmware upgrade.

thanks for information. I read this topis but I did not find a solution to the problem. Apparently, the latest firmware version is coruppted

The below image is from my 2nd generation My Cloud and so far I haven’t experienced any problems.