USB to NAS/NAS to USB back up doesn't work

Dear community,

For the first time I’m writing a post due to my immense frustration since I bought the My Cloud EX2 Mirror.

I struggled a lot to make it work one year ago and since then I managed to use it without getting mental although I wasn’t very happy with it due to its quite difficult technical inclination.

Recently I reached a point that I had to upgrade the HD to 4T and I decided to invest on them.

Bought both WD HD 4T, installed, set on RAID 1(Auto-Rebuild ON)and with my surprise I couldn’t make the USB to NAS and vice-versa working. I spent whole day yesterday working on it without success. Very frustrating especially when you have to transfer 2T of stuff. I read a lot thread about this problem and apparently the WD support didn’t help at all. Someone from the frustrated users suggested different advice but nothing worked for me.

On top of that I’ve realised that WD My cloud use a Linux Swap partition that it is not readable on Mac. I wasn’t aware of. How can I overcome on that? If one day the NAS will stop working and I have all my files on both RAID HD how can I re-ingest them back in my computer? I tried to use MAcFuse and OsxFuse unsuccessful. I’m not an IT guy and I struggle a bit dealing with this stuff.

So, is there anyone that can help me out to fix this problems?

Is anyone from WD out there that can fix these problems???

I hope to get an answer.

Many many thanks!


One work-around is to use the built-in web file viewer app in the dashboard to move/copy files. The USB drive should automatically be created as a share when plugged in, and you can use the app to move or copy files between shares, so it can be used to make a transfer.

What you’ll find is that the connection to the dashboard will probably time-out before your transfer is done (especially if it’s 2TB), but it will carry on in the background anyway (although from that point onwards there’s no way to actually monitor or cancel it that I know of). You can only move one folder at a time, but with a bit of preparation (moving all the folders you want to transfer into a single mother folder, transferring that and then rebuilding your folder tree on the target end afterwards) it does work.

I used that method to populate my 5TB elements drive which I have hooked up to my MCM, took about a day to do the full transfer (also about 2TB worth of files, similar to yours). It has the advantage of being a direct USB3 transfer, so is about as fast as you can get. Don’t try to do it via a computer (other than for remote connecting to the dashboard), as (for example) doing a drag and drop transfer using Windows Explorer with the MCM and USB drives as SMB or networked share drives will just results in all files going via the computer, which slows everything to a crawl (especially if wifi is involved).

You are right that USB<>NAS backup seems to be somewhat unreliable (to be diplomatic) on recent firmware. It’s a shame, as it did used to work, and is something that should definitely be looked into by WD tech.

Editted to add - also depending on how comfortable you are with Linux, have a look at this post which may give you another option to do this from the command line.

Dear Darren,

Thanks a lot for your advise.

I tried what you suggested but it doesn’t work for me.

It always gives error.

I called WD support as well, they gave me others advice but no luck. The transfer still failing.

I hope to manage to restore my files ASAP and get a FULL refund from this unreliable system.

I need to find out how to copy files from the Linux partition directly in my Mac HD and then I will get rid off the NAS.

I am very very very disappointed with it.

I hope someone from WD read this post!


PS Is there a “phisical” support from WD in London? I mean a place where to go to ask support?

No, they don’t do physical support, aside from the phone/email that you already tried. And they don’t normally read here (it’s a user forum, all of us are WD users sharing knowledge and experience rather than WD staff). In some cases the moderators do refer posts to WD, but all you’ll get then is contact via PM to arrange a telephone support call like the one you already had.

You could try again with WD support (00800- 27549338) and see if they can refer it to someone higher up in their support structure, but aside from that all I can think of is to try and transfer your files in small batches if a longer full transfer all at once fails.

Thanks Darren,

I’ve managed to mount the HD using a dock station and MacFuse on my iMac.Transfering the all files.It will take a while :frowning:

Then I will try to ask for a refund.

I have enough of this system.

Many thanks again!


Hi Darren

Many thanks for this suggestion - which works for me :slight_smile:

I’ve been struggling for days to find a solution to the fact that currently the backup to USB device still does not work.

I’ve followed lots of threads and stumbled on this one at last!

By bumping this up to the top I hope it helps some of the many others who are still struggling…

Thanks again,