USB Backup failure

I’m trying to backup my EX2 Ultra to an external hard drive via the USB Backup App.

I’m running on Mac OS Big Sur. The firmware on the EX2 Ultra is 5.17.107. The drive is a Seagate 5TB Backup Portable Plus. It’s formatted to exFAT as per the instructions. I want to copy a folder of about 2TB that has all my data but it runs for a few minutes and fails. It offers no explanation besides: “Backup failed. Please check your system settings”. I’ve tried resetting the device, trying different ports, trying different format types of the drive. Nothing works.

Incredibly frustrating! I’m having another issue with it where it is almost always impossible to delete files off of it. I’ve spent days trying to figure it out but WD tech support doesn’t know why. I’m reluctant of asking them further about things, so hopefully somebody here can help? Thanks so much!

I run BOOTCAMP on some of my mac systems just because of problems like this.

then I format the external drive using Windows format NTFS and use USB Backup App
(the sync backup option has a small problems with exfat file time stamps)

There are programs to let mac computer read windows format NTFS

You are right that exFAT is recommended for easy read/write between mac and PC

AND- are you accessing the external USB over the network while it is connected to the NAS or removing it from the nas and using USB cable to mac ?