USB 3 Elemental 10B8 Continually Disconnects & Reconnects

This worked fine on my older Dell on USB 3. Got an HP Pavilion 590-p0044, and now it keeps disconnecting/connecting. Sometimes it refreshes the icons on my taskbar. I have 4 back USB 3.1 and it happens on them all. Not on the 2 USB 2 back ports. Not on the 2 front USB 3.1 ports. Only the 4 in back. I tried turning off ability to put to sleep on all USB options. Tried changing Power Options. My cord is not too long. It’s rather short (Not sure if I can go shorter and still be bale to plug it in.). Tried disabling my HDD under Device Manager Portable Drives. Same nothing. Tried installing AMD USB 3.0 Host Controller & AMD USB Filter Driver. No change. Windows 10 says I’m using the latest drivers. I even tried uninstalling all USB Root hubs. Still disconnects & reconnects.
When configured, Events says:
Device USBSTOR\Disk&Ven_WD&Prod_Elements_10B8&Rev_1012\57584B314543344633393945&0 was configured.

Driver Name: disk.inf
Class Guid: {4D36E967-E325-11CE-BFC1-08002BE10318}
Driver Date: 06/21/2006
Driver Version: 10.0.17134.1
Driver Provider: Microsoft
Driver Section: disk_install.NT
Driver Rank: 0xFF0006
Matching Device Id: GenDisk
Outranked Drivers: disk.inf:GenDisk:00FF2002
Device Updated: false
Parent Device: USB\VID_1058&PID_10B8\57584B314543344633393945

When started, Events says:
Device USBSTOR\Disk&Ven_WD&Prod_Elements_10B8&Rev_1012\57584B314543344633393945&0 was started.

Driver Name: disk.inf
Class Guid: {4D36E967-E325-11CE-BFC1-08002BE10318}
Service: disk
Lower Filters:
Upper Filters:

No matter what, those 4 Back USB 3.1’s will not maintain connection to my HDD.

It is recommended to run health test on WD Elements using Data Lifeguard Diagnostic Tool to check the health of the drive. If Fails, then drive should be replace under warranty.
Otherwise, you can also use another data cable to connect with computer.

The drive passes the Data Lifeguard Test. Don’t have another cable to try, but considering it works fine when connected to the USB 2.0 and front uSb3.1, I can’t see the cable being the problem for just those back USB 3.1

The problem might be my HDD is not migrating (whatever that means):
Device USBSTOR\Disk&Ven_WD&Prod_Elements_10B8&Rev_1022\57584B314543344633393945&0 was not migrated due to partial or ambiguous match.

Last Device Instance Id: USBSTOR\Disk&Ven_SanDisk&Prod_Cruzer_U&Rev_1.27\20044320010F30709DD2&0
Class Guid: {4d36e967-e325-11ce-bfc1-08002be10318}
Location Path:
Migration Rank: 0xF000FC000000F120
Present: false
Status: 0xC0000719
Is there anyway to migrate my device?