Urgent help needed: files no longer play (stuck at loading arrow)

Youtube works, but files no longer play. Tried 3 different drives and files…


On FW 1.13.18

Will it work if I reflash?

Rollback doesn’t work either.

It’s like once you click on the file, the PLAY command doesn’t get executed, it’s just stuck in the circular arrow.

Files that play before no longer play, nothing plays…

Is it corrupted metadata?

Ok, reflashed back to latest, still not working.

Same problem occurs for Photos and Music, it just keeps spinning without loading the file name and progress bar.

Photo preview works, and so does anything that is not PLAY.

Any advice? Seems like some corruption in functionality, but I have reset to Factory twice, and reflashed firmware twice also…

Good luck with this. I have same problem and find it raised in several threads in WD support forums with no solution.

Some people have reported success with;

  • disable screen saver

  • update firmware

  • reset using hidden reset button (underneath)

Personally I have tried all these and it hasn’t helped at all. The only thing that gets it working is a reboot, then it will work for a while but problem comes back. At least it doesn’t (yet) fail in the middle of playback.

Can’t seem to get an answer on it. So we just reboot it everytime we want to use it.

This problem occurred without changing ANYTHING on the WDTV. It was working one moment (had been for months since new), then this fault appears. Probably end up throwing it away.

There’s a know bug with messed up files. Each file played afterwards will also not play until the player is powercycled. Have you tried playing back other files instead?

Tried flashing, tried new drives, tried old/new files.
Will try the screensaver thing
(Where’s tech support)

Hi Techflaws, all the files won’t play, and they were verified on a PC.

Some files were just played before this problem.

The drives are also healthy FS wise and sector wise.

I had also did a fresh thumbdrive with an mp4, mkv and a 3gp, all which worked.

Mp3s also failed, as well as photos (JPGs). What’s weird is that the JPGs generated previews on the fly without problems (I cleared the thumbnails).

Really weird eh

I think deep in the WDTV’s storage the player’s files screwed.

Oh Mr Tech support… is there a way to restore these?

I have the EXACT same problem.  Mind you before these awesome firmware updates, my device was flawless and played the formats just fine.

I do NOT have a permanent fix for it, but I found that by selecting “Device Reset” it would play AVI files.  It still, however , will not let me pause, FF, Rew, or anything else.  If I make the mistake of trying any of those, I get a message box saying it cannot play the selected format…  Really?  I’ve been watching it for a HALF HOUR!

The worst part is that I have to do that after EVERY .avi FILE I WANT TO WATCH.

This device **bleep** and apparently the tech support isn’m much better since you started this thread in 2012 and it’s now… well 2013.

Not sure that’s the same issue extremejm.

The problem I have, which I think is the same as the OP is that after device reboot (from power off - remove power) it plays and everything works fine, but after approx 30 mins, nothing will playu from any source. you just get spinning orange arrow. no error.

Power reset and everything works again for a while. You can watch a 2 hour movie no problems but leave the device idle for 30 mins and the next file you play won’t work.

I’ve seen many suggestions this is due to bad files, but that makes no sense. If the files are bad then why can you play them perfectly well after a reboot. It isn’t files that induce the failure because even If device is rebooted and left idle for 30 mins, nothing at all will play, whereas if you reboot and play immediately, anything will play.

I just tried rolling back to the oldest available firmware and it makes no difference. I also tried renaming the media server in case something about it’s identity was being kept in the WD./ No difference.

I also tried playing from another source (USB, different type of media server on different host) and it makes no difference. I can play all my media on my PS3 from the same media server and never have any problem.

The WDTV never had any problem either, for months since new. This just suddenly happened and now I have a near useless pieve of junk. Support seems to be ignoring it other than to suggest firmware updates, resets, etc that we all know don’t solve it.

This is a user to user forum so you will not get WD tech support here. If you want WD tech support you need to contact them.

mine doesn’t  have a working period at all, it’s just not working. will try to get it exchanged, as it’s under warranty.

if there’s a window where it works, what does that mean? buffer/mem exhaustion?

anyway discovered something else: the SMB is wonky. Can’t write to a WDTV hosted HDD. It will show some permission errors and after some time you find the HDD hasn’t changed at all.

Ok after the SMB error, I got desperate and went to try wdlxtv’s new homebrew hack. (b-rad)

All I did was to enable the homebrew, I didn’t even load the BIN.

I think it reset the file permissions.

And all is working again.

Ok I got the error again, only after I tried to copy 48GB of photos back over WDTV to PC… lol think there is something related to file lock or SMB lock or resource lock…

ok I’m back to the “standard” reset every time solution of poking the RESET hole.

what happens is if I eject the drive, I lose it. This happens with/out power cycling/reset etc.

Have added a second HDD while the first one is still working.

Still works.

Hope it lasts… sigh

have a look at this…


maybe uPnP on your network somewhere causing the WD to die.