Can not play certain files after FW upgrading

Hi guys. I’ve updated my WDTV HD media player through the Internet to 1.06.15_V yesterday, then started having problem with playing some files that I used play before.

I used play a TV series in avi format with .smi subtitles before, but the files are no longer played after FW update.

Some avi files are still played good but some are not.

And after trying the avi files that didn’t work, other avi files that were played well before, also don’t work at all unless I restart the WD media player.

When I pressed the button to update the FW, I was expecting a better performance but it seems like my WD player got worse.

Should I down grade the FW? I’ve already tried deleting the .WD_tv folder and resetting both pin button and software reset but it didn’t help me at all.

Is there anyone has same issue like mine?

Have you tried unplugging it for a while before trying the “won’t play” media?

If that doesn’t work… roll back to one that works for you.