Upload files not complete to my cloud

My device WD mycloud ex4 24TB

The device is working good in local lan but, when i trying to access device from outside through (my cloud App desktop) or my account on (mycloud.com) i cannot upload files … upload start and not complete … i can (download-delete) and browsing files but for uploading i cannot … i am trying to upload small files like (word-excel) not too big.

i need solution .

Is this happening from any external location you have tried?

yes from any external location, i tried it from the same country and outside my country and the same problem.

i can access files and delete or download but i cannot upload files. :pensive:

Perhaps it would be best to send an E-mail to WD Support about this in the following link:

Try to provide as many details as possible related to what you have tried so far and the fact you are able to download files, which means a connection is established. They may contact you if they need additional information.

when i try to create new ticket application give the following warning error :-

Please fix the following:
Please enter a valid model number.

Same thing happanes if I use WD My Cloud app (version 1.0.17) it shows an error “Problems Found”

Only files smaller than 1 KB get uploaded.

Which router you are using ?

I have the same problem did u found the solution?