Upgrading to larger drives PR4100

I have a PR4100 with 4 x 2 tb drives in RAID10 and it is becoming full. I didnt really foresee how much data space I would need. So what is the best option for growth here? I know I need to get 4 new drives of a larger capacity, say 4gb but what is the procedure?

Hello ixnay,

Please refer to the below link to know more about replacing the drives on a PR4100:

Recently bought a 16TB PR4100 realize that I should have got the 40TB unit. Have it working in a RAID5 config.

Here’s my question.

If I pull one of the 4TB drives and replace it wth a 10TB drive, will it rebuild the RAID5 leaving the 6TB unused?

If I proceed to do this 4 times can I then utilize some command (via ssh or ?) to expand and use the full 40TB?

This would be a slow process I know. rebuilding the array after each drive swap, however it would be non-destructive.

I’m Interested in this topic, i need to expand too. from 24TB raid 5 to 40TB.
Found in the firmware!!! LOL

You won’t be able to expand an existing volume to a volume over 16TB.
The tools to resize EXT3 file systems are outdated (e2fsprogs and resize2fs)… you need at least v1.43
See here

You are able to

  • create larger volumes from scratch
  • rebuild an existing volume (after replacing 1 disk)

You may not be able to

  • expand existing volumes over 16TB

Some time ago I tried to go from RAID5 4x4 TB to 4x8 TB and the rebuild was successful but I couldn’t expand my capacity. To top it off, my 8 TB drives were stuck as you can’t go back and rebuild with the 4 TB disks…

I hope that the support team can confirm this.

The link above does provide instructions to bypass this limitation but it’s quite challenging to do this on the PR4100.
I’d install entware on a USB flash drive with a recent version of e2fsprogs (it has v1.43.5) or use git to get the latest version.
Then find a way to unmount your RAID5 volume (stop all services first) … and follow the rest of the guide.

Disclaimer: this is quite advanced stuff, you may lose your data. Do it at your own risk.
Rebuilds take almost 24h for a single 4 TB disk. Use a backup UPS.

EDIT: I’ve heard reports that WD has patched their version of e2fsprogs so you can expand beyond 16TB.

1 Like

This link’s info seems directed to replacing a faulting drive with the EXACT same SIZE, not answering the question about UPGRADING the SIZE. Can’t you answer the question, instead of deflecting?

1 Like

When you’ve replaced all disks with bigger drives, an option becomes available in the RAID menu to expand the volume.

So if I buy (4) WD Gold 12TB eHDD and replace all (4) 8Tb Red’s (one at a time), I can then ‘expand’ my RAID 10 configuration of my PR4100 NAS, gaining 8Tb more of storage.

Thanks, one might think this info would be readily available from WDC.

John, Did this actually work for you? If so, what version of the firmware? Thanks.

I never pulled the trigger on this plan, I called India, I mean WDC Support and they could only approve the 8TB drives that came with my PR4100. They don’t know anything that WD is doing in product development as I bought a PR2100 that came with 10TB drives, regarding firmware my PR4100 and my PR2100 are both running with version 2.31.149.

Also the best I could get from India, I mean WDC Support, regarding drive replacement wasn’t real confident towards retaining my existing data, when increasing/upgrading drive sizes, IE: you bought a PR4100 with 4TB drives and you want to increase to 8TB, expanding storage size would require a ‘formatting’ type operating resulting in ‘blank’ drives with more available storage.

One would think, what difference the size of the drive makes, but I don’t know regarding WD’s NAS O/S and don’t have access to the operating system, like with Windows.

I’m using both WD NAS units for PLEX Media Servers, I went with the PR2100 20TB, RAID 1, and got 10TB of storage, the second time; as opposed to the PR4100 32TB, RAID 10 with 16TB of storage, the first time. The PR4100 configuration seemed like overkill for the money difference.

1 Like

I have a problem in this area as well! I have PR4100 with latest firmware 2.31.204, I had 4X2TB installed in RAID 5 configuration and decided to upgrade to 4X4TB drives. I shut down the NAS- pulled one existing drive out - put a new drive in - NAS switched on tells me it is rebuilding volume - then when done, I repeat for remaing drives.

Finally all four have been rebuilt BUT mu total space is 5.94TB - which same as it was with 4X2TB…

I cannot see the option to extend capacity as shown on picture from Kiwivda!

I found a note on RAID page :
To create a new volume from the remaining available storage space, click [here](javascript:Remain_Linear_Format();).

But I do not want a new volume - I have all drives mapped in my system.
Anyone has any suggestions?

Anyone can help finding way to extend storage as shown

I do have the original drives I can put back but that does not really help.

Need HELP badly.

I think I found the way - BUT I need to test it and it will take some time!
go to
Raid Profile
Change RAID mode
raid 5
Expand capacity
Then start rebuilding using new drives.
I am not sure if I need to format drives first or could rebuild using the drives with data already

All worked perfectly (but had a few scares).
The above steps finished after two days of rebuilding but the total capacity was still reported a 5.3TB - I almost started over - but then decided to look at drives statis and saw that RAID was now reconstructing - took another 5 hours and then I got 11.8TB space available from 4X4TB in Raid 5.
The manual has no help and the user inerface does not guide you to the necessary steps.


Sorry for the year in late, glad to know you went through.

Worked on rebuilding first (swapping with auto rebuild turned on) with all new bigger drives (swapped 3’s for 6’s) Once all my data was there on the new drives I went in an extended the RAID…
Clicked This:

And saw this:

Clicked Extend and Clicked Next. (apologize for this bad drawing)

Its the slowest method as you have to rebuild and then extend after but… I think its the safest. It’s good/nice to see all your data there after you switch all your drives before you extend.

Hope this helps.

1 Like

I didn’t see the extend option either for my RAID10 array of 4x1TB
I did the power off, replace, and auto rebuild for my new replacement drives of 4TB
All items on the ‘Change Raid Mode’ page show as ‘Switch to RAID X’, no extend/expand option

How do I now make sure of the extended space on the same volume?

Pictures below for reference

I ran out of storage 4X4TB, I replaced only one (bad) disk with 6TB disk. the option for expand capacity appeared as in picture only for RAID 5, I haven’t tried it yet. my current RAID configuration is RAID 5.

As soon as I used the remaining 2TB for spanning, the option disappear. I also deleted some 2.5TB unnecessary files. So I thing the option to expand Capacity might have disappeared due to either reasons.
it might have appeared in the first place due to lack of space, I was down to only 17 GB out of 12TB.
so I am thinking it might be triggered by lack of space too.
I will try later to add the 2.5TB again to see if this could trigger the option to expand.
or remove the disk that has the extra 2TB spanning and swap it with a larger disk and check If the option comes back.
I will update later

1 Like

So, it turned out the option to expand doesn’t get triggered by lack of space. it works only when you replace one of the disks with larger one. after rebuild the system will give you the option to expand.

Once you start the process, it will ask you to remove the first disk, it will be marked with red light. In my case the first disk to replace was Drive 1 the same new larger one who triggered the expansion. and even the NAS spent 7-8 hours rebuild this one you will have to do it again for the sake of expansion this time. so I just opened the door for it to disconnect and closed it again. 7-8 hours later it asked me for the next drive and so on.
attached are screen shots during the process.

I will post the final image for the expanded NAS (from 4x4TB to 4x12TB in Raid 5 configuration) once it is done.

Raid is being verified after finishing expanding

the original 8GB RAM won’t be enough though

thank you for the valuable note. I think you mean this:

it seems like raid 10 is more suitable in this situation. and I would get 24TB in total instead of 36TB which is still better than the 12TB that I maxed out.
is there anyway to change raid without erasing?
or should I change raid to 10 and recover from a backup?
I wish Raid 6 is an option

I just want to add that this guide is great and demonstrates the process exactly.
I replaced 4x2Tb drives with 4x10Tb drives. once they were all updated, I followed the steps above and the drive I had expanded to ~30Tb. The drive remained available during the process, although streaming Plex movies was difficult during the expansion. It took about 6 hours to expand each drive, so it took me a day and a half to expand all four drives, then about an extra 6 hours to verify the parity.
At this stage I have had no issues with the 8Gb ram, but it would be rare for my to stream more than two movies at once.
I would still recommend a backup, as a power disruptions could potentially ruin the volume.

Bashaar -
Thank you for sharing these step by step instructions. Extremely helpful.
I am looking to expand the capacity of my PR4100. I have four WD Red 6TB drives.
What is your recommendation to go with for double capacity? Should I select the Red Plus drives?
I have gone through replacing all of my original drives as they have failed over the couple years. I am using RAID 5, so it is a relatively painless process to swap a bad drive. But capacity is my next challenge. Looking for any guidance you can share.

Thank you -

my experience was quite different. of course i backed everything up first (this took a week as i had 21Tb of stuff to move around).

My PR4100 NAS had the latest firmware … RAID-5 was healthy … each of the 4 8Tb NAS drives were in good operating order and temps were fine. I’ve used this setup since i bought the PR4100 nearly 2 years ago. no issues/problems, however i was running out of space so the drive capacity upgrade was necessary. The PR4100 was configured in RAID-5 … 32Tb of total disk space … 23.7Tb of usable space … 20.5Tb of consumed disk space. RAID Auto-Rebuild was enabled. As with other posters, i too updated the RAM from the 4Gb to 16Gb as i use this as a media server. RAM/CPU/NETWORK all show as good/healthy/minimally used (no concerns w/the hardware).

i purchased 4 20Tb NAS RedPro drives … i started the hot-swap in BAY 1 (closest to the power button) … took the 8tb out, put the 20Tb in … it started the rebuild process but after 5 minutes said “rebuild failed”, and then drive 2 status went “red”. It didnt give any specifics concerning the failure, just that the rebuild failed. Also, the webpage now showed drive 2 as “bad”. i powered down the unit, put the 8tb back in, powered up the PR4100, it rebuilt the raid but in “degragated” status, but drive2 then showed as good.

i tried this 2 more times, same results … the rebuild after the hot-swap fails after 5 minutes (and it calculates something like 2.5 days to rebuild).

i also tried this method with the RAID Auto Rebuild turned off (so Manual rebuild) … it looked to be doing better, but after 10 minutes (again, w/2.5 days calculated to complete the rebuild), it too failed.

after all this, i said screw it … power cycled the PR4100 down … pulled all 4 8Tb NAS drives out … put in 4 20Tb NAS drives … powered it up … and built a new RAID-5 w/the new 4 20Tb NAS drives.

kindof disappointed this upgrade process didn’t work for the 20Tb NAS drives

at least i had a backup and could complete the restore manually (in about a week)