Upgraded firmware now won't sleep

Not really sure what came over me but I decided to upgrade to the latest firmware. This went pretty well and required a reboot of MC and my PC afterwards.

But now it won’t sleep. I woke up this morning and the MC light was solid blue and the drive was spinning. I wasn’t accessing it as it is only used as a backup destination.

Went into SSH and ran TOP. apache2, upnp_nas_device, and wdmcserver were bouncing around near the top. I have all of the media streaming, itunes, etc turned off. The only thing I have turned on is email notification, SSH and NTP. I turned media streaming and itunes on then back off again and rebooted. That seems to have stopped wdmcserver from running.

What else can I check to see why it is not sleeping after the latest firmware?

Hi,

Please try performing a system only reset and check the settings for the energy saver.

See page 58 of the users manual:

Check the /var/log/user.log for errors. Such as missing file. There is a know problem that a message is written to the log every minute or more. The way to fix this error is to stop the restsdk-serverd process.

RAC

PS rebooting will not fix this problem. IN fact devery time you reboot it will start this process again.

Do you know what restsdk-serverd does?

Should I just stop it from running?

I don’t know what it does. It came out the latest round of firmware updates. The latest firmware talks about software development kit. Since the process name has sdk in it. I think it has something to do with the sdk.
It has been turned off on my system for a long time. No adverse effects so far.

RAC
PS There is a user-start file linked to by /etc/rc2.d/S98user-start. This file does not get changed when firmware is updated. So you can put comands in this file to stop those processes that you want to not run.

I followed the first few steps of this and added ‘exit 0’ to the beginning of wdmcserverd, wdphotodbmergerd, and restsdk-serverd. I’m sure there are more elegant ways to keep these from running but this seems to work. The drive eventually went to sleep. It does however wake up as soon as I click on Network in Windows Explorer. I guess that is OK.

I have a backup job that runs every night through Windows at 2:01 am so that wakes it up and from what I see in user.log it is waking back up at 3:00 am. Maybe Hillary is calling…

The 3:00am wake up is to do house keeping like checking for firmware upgrades. I’m not sure why people want to go in and modify WD’s code. When the easy way is to edit the user-start file. This way the last thing done on every boot is to stop those processes that you don’t want to run or make changes you need for your setup. This way you make no changes to the WD code. If you want to boot up the Cloud and not use your changes just put the exit 0 in the user-start file.

RAC

I created a user-script file /CacheVolume that contains:

/etc/rc2.d/S85wdmcserverd stop
/etc/rc2.d/S86wdphotodbmergerd stop
/etc/rc2.d/S92wdnotifierd stop
/etc/rc2.d/S20winbind stop
/etc/rc2.d/S20minidlna stop
/etc/rc2.d/S85twonky stop
/etc/rc2.d/S50netatalk stop
/etc/rc2.d/S60mDNSResponder stop
/etc/rc2.d/S95wdAutoMount stop
/etc/rc2.d/S20nfs-common stop
/etc/rc2.d/S20nfs-kernel-server stop
/etc/rc2.d/S61upnp_nas stop

I found these entries in this post. Will that let this beast get some rest?

All I need it to do is hang out all day and wait for the 2:01 robocopy command to read the contents and copy what is necessary from my source drive. I do have an external USB drive connected to it. Should I remove any of the above lines to be able to use the USB?

If you didn’t install the minidlna package you don’t need to have that line in your file. Minidlna is not a standard package.

RAC

My backup ran fine at 2:01 am then I guess it woke up at 3:00 am again. This is what is in my user.log:

2015-12-07T03:00:17.351770-08:00 di=uxnai36ycX notice restsdk[6913]: watch.go:109: Stat(), error: stat /tmp/dynamicconfig.ini: no such file or directory

2015-12-07T03:00:19.066665-08:00 di=uxnai36ycX notice restsdk[6913]: watch.go:109: Stat(), error: stat /tmp/dynamicconfig.ini: no such file or directory

2015-12-07T03:00:29.070217-08:00 di=uxnai36ycX notice restsdk[6913]: watch.go:109: Stat(), error: stat /tmp/dynamicconfig.ini: no such file or directory

2015-12-07T03:00:39.071298-08:00 di=uxnai36ycX notice restsdk[6913]: watch.go:109: Stat(), error: stat /tmp/dynamicconfig.ini: no such file or directory

2015-12-07T03:00:49.073046-08:00 di=uxnai36ycX notice restsdk[6913]: watch.go:109: Stat(), error: stat /tmp/dynamicconfig.ini: no such file or directory

2015-12-07T03:00:59.074524-08:00 di=uxnai36ycX notice restsdk[6913]: watch.go:109: Stat(), error: stat /tmp/dynamicconfig.ini: no such file or directory

2015-12-07T03:01:01.896590-08:00 di=uxnai36ycX notice BaseOSlog: { “msgid”:“dataSize”, “mountPoint”:"/", “capacityK”:1968336, “totalK”:652992, “partition”:“rootfs” }

2015-12-07T03:01:01.934050-08:00 di=uxnai36ycX notice BaseOSlog: { “msgid”:“dataSize”, “mountPoint”:"/", “capacityK”:1968336, “totalK”:652992, “partition”:"/dev/root" }

2015-12-07T03:01:01.968553-08:00 di=uxnai36ycX notice BaseOSlog: { “msgid”:“dataSize”, “mountPoint”:"/run", “capacityK”:40960, “totalK”:3904, “partition”:“tmpfs” }

2015-12-07T03:01:02.003354-08:00 di=uxnai36ycX notice BaseOSlog: { “msgid”:“dataSize”, “mountPoint”:"/run/lock", “capacityK”:40960, “totalK”:64, “partition”:“tmpfs” }

2015-12-07T03:01:02.043826-08:00 di=uxnai36ycX notice BaseOSlog: { “msgid”:“dataSize”, “mountPoint”:"/dev", “capacityK”:10240, “totalK”:0, “partition”:“tmpfs” }

2015-12-07T03:01:02.063542-08:00 di=uxnai36ycX notice BaseOSlog: { “msgid”:“dataSize”, “mountPoint”:"/run/shm", “capacityK”:5120, “totalK”:0, “partition”:“tmpfs” }

2015-12-07T03:01:02.083044-08:00 di=uxnai36ycX notice BaseOSlog: { “msgid”:“dataSize”, “mountPoint”:"/tmp", “capacityK”:102400, “totalK”:3008, “partition”:“tmpfs” }

2015-12-07T03:01:02.110173-08:00 di=uxnai36ycX notice BaseOSlog: { “msgid”:“dataSize”, “mountPoint”:"/var/log", “capacityK”:40960, “totalK”:10048, “partition”:“ramlog-tmpfs” }

2015-12-07T03:01:02.129791-08:00 di=uxnai36ycX notice BaseOSlog: { “msgid”:“dataSize”, “mountPoint”:"/DataVolume", “capacityK”:3841069352, “totalK”:1915994748, “partition”:"/dev/sda4" }

2015-12-07T03:01:02.335179-08:00 di=uxnai36ycX notice BaseOSlog: { “msgid”:“dataSize”, “mountPoint”:“a50f01f9d65ab99f50c2c1e7d09212b2/var/media/”, “capacityK”:3906983932, “totalK”:2090669904, “partition”:"/dev/sdb1" }

2015-12-07T03:01:02.392202-08:00 di=uxnai36ycX notice BaseOSlog: { “msgid”:“inodeUsage”, “filesystem”:“rootfs”, “inode”:125184, “iused”:25273, “mountPoint”:"/" }

2015-12-07T03:01:02.411624-08:00 di=uxnai36ycX notice BaseOSlog: { “msgid”:“inodeUsage”, “filesystem”:"/dev/root", “inode”:125184, “iused”:25273, “mountPoint”:"/" }

2015-12-07T03:01:02.431225-08:00 di=uxnai36ycX notice BaseOSlog: { “msgid”:“inodeUsage”, “filesystem”:“tmpfs”, “inode”:1815, “iused”:246, “mountPoint”:"/run" }

2015-12-07T03:01:02.450787-08:00 di=uxnai36ycX notice BaseOSlog: { “msgid”:“inodeUsage”, “filesystem”:“tmpfs”, “inode”:1815, “iused”:5, “mountPoint”:"/run/lock" }

2015-12-07T03:01:02.470250-08:00 di=uxnai36ycX notice BaseOSlog: { “msgid”:“inodeUsage”, “filesystem”:“tmpfs”, “inode”:1815, “iused”:175, “mountPoint”:"/dev" }

2015-12-07T03:01:02.489881-08:00 di=uxnai36ycX notice BaseOSlog: { “msgid”:“inodeUsage”, “filesystem”:“tmpfs”, “inode”:1815, “iused”:2, “mountPoint”:"/run/shm" }

2015-12-07T03:01:02.509371-08:00 di=uxnai36ycX notice BaseOSlog: { “msgid”:“inodeUsage”, “filesystem”:“tmpfs”, “inode”:20480, “iused”:79, “mountPoint”:"/tmp" }

2015-12-07T03:01:02.536205-08:00 di=uxnai36ycX notice BaseOSlog: { “msgid”:“inodeUsage”, “filesystem”:“ramlog-tmpfs”, “inode”:1815, “iused”:115, “mountPoint”:"/var/log" }

2015-12-07T03:01:02.555422-08:00 di=uxnai36ycX notice BaseOSlog: { “msgid”:“inodeUsage”, “filesystem”:"/dev/sda4", “inode”:243900416, “iused”:20694, “mountPoint”:"/DataVolume" }

2015-12-07T03:01:02.678215-08:00 di=uxnai36ycX notice BaseOSlog: { “msgid”:“inodeUsage”, “filesystem”:"/dev/sdb1", “inode”:0, “iused”:0, “mountPoint”:“a50f01f9d65ab99f50c2c1e7d09212b2/var/media/” }

2015-12-07T03:01:06.446839-08:00 di=uxnai36ycX notice BaseOSlog: { “msgid”:“usageSize”, “totalB”:2002737398416, “photos”:5514904914, “video”:1950765719432, “music”:3790274252, “other”:42666499818 }

2015-12-07T03:01:09.106124-08:00 di=uxnai36ycX notice restsdk[6913]: watch.go:109: Stat(), error: stat /tmp/dynamicconfig.ini: no such file or directory

2015-12-07T03:01:19.108097-08:00 di=uxnai36ycX notice restsdk[6913]: watch.go:109: Stat(), error: stat /tmp/dynamicconfig.ini: no such file or directory

2015-12-07T03:01:29.109627-08:00 di=uxnai36ycX notice restsdk[6913]: watch.go:109: Stat(), error: stat /tmp/dynamicconfig.ini: no such file or directory

2015-12-07T03:01:39.111562-08:00 di=uxnai36ycX notice restsdk[6913]: watch.go:109: Stat(), error: stat /tmp/dynamicconfig.ini: no such file or directory

2015-12-07T03:01:49.114257-08:00 di=uxnai36ycX notice restsdk[6913]: watch.go:109: Stat(), error: stat /tmp/dynamicconfig.ini: no such file or directory

2015-12-07T03:01:59.115671-08:00 di=uxnai36ycX notice restsdk[6913]: watch.go:109: Stat(), error: stat /tmp/dynamicconfig.ini: no such file or directory

2015-12-07T03:02:09.117284-08:00 di=uxnai36ycX notice restsdk[6913]: watch.go:109: Stat(), error: stat /tmp/dynamicconfig.ini: no such file or directory

2015-12-07T03:02:19.119105-08:00 di=uxnai36ycX notice restsdk[6913]: watch.go:109: Stat(), error: stat /tmp/dynamicconfig.ini: no such file or directory

There is also a user.log.1 file with similar entries.

Also even though I have a ‘upnp_nas_device stop’ line in my user-script it was running this morning.

In /CacheVolume I have a user-script that contains these 12 lines

/etc/rc2.d/S85wdmcserverd stop
/etc/rc2.d/S86wdphotodbmergerd stop
/etc/rc2.d/S92wdnotifierd stop
/etc/rc2.d/S20winbind stop
/etc/rc2.d/S20minidlna stop
/etc/rc2.d/S85twonky stop
/etc/rc2.d/S50netatalk stop
/etc/rc2.d/S60mDNSResponder stop
/etc/rc2.d/S95wdAutoMount stop
/etc/rc2.d/S20nfs-common stop
/etc/rc2.d/S20nfs-kernel-server stop
/etc/rc2.d/S61upnp_nas stop

I just shutdown MC and cycled the power. SSHed and ran top command and some of the above are still running. How do I track down why they are still running?

Top results

Tasks: 94 total, 1 running, 93 sleeping, 0 stopped, 0 zombie
%Cpu(s): 0.0 us, 0.7 sy, 0.0 ni, 99.3 id, 0.0 wa, 0.0 hi, 0.0 si, 0.0 st
KiB Mem: 232320 total, 174784 used, 57536 free, 6656 buffers
KiB Swap: 500672 total, 89728 used, 410944 free, 40256 cached

PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
9797 root 20 0 4608 3776 1664 R 0.7 1.6 0:00.35 top
2508 root 20 0 0 0 0 D 0.3 0.0 0:04.46 pfe_ctrl_timer
6926 root 20 0 854m 9088 4032 S 0.3 3.9 0:01.60 restsdk-server
7507 root 20 0 36736 8384 3648 S 0.3 3.6 0:06.75 wdmcserver
1 root 20 0 2752 1408 1088 S 0.0 0.6 0:08.58 init
2 root 20 0 0 0 0 S 0.0 0.0 0:00.00 kthreadd
3 root 20 0 0 0 0 D 0.0 0.0 0:00.00 cpu1_hotplug_th
4 root 20 0 0 0 0 S 0.0 0.0 0:01.19 ksoftirqd/0
5 root 20 0 0 0 0 S 0.0 0.0 0:00.49 kworker/0:0
7 root rt 0 0 0 0 S 0.0 0.0 0:00.00 migration/0
8 root rt 0 0 0 0 S 0.0 0.0 0:00.00 migration/1
10 root 20 0 0 0 0 S 0.0 0.0 0:00.58 ksoftirqd/1
11 root 0 -20 0 0 0 S 0.0 0.0 0:00.00 khelper
37 root 20 0 0 0 0 S 0.0 0.0 0:00.45 kworker/1:1
230 root 20 0 0 0 0 S 0.0 0.0 0:00.00 sync_supers
232 root 20 0 0 0 0 S 0.0 0.0 0:00.00 bdi-default
234 root 0 -20 0 0 0 S 0.0 0.0 0:00.00 kblockd
240 root 0 -20 0 0 0 S 0.0 0.0 0:00.00 ata_sff
251 root 20 0 0 0 0 S 0.0 0.0 0:00.22 khubd
257 root 0 -20 0 0 0 S 0.0 0.0 0:00.00 md
280 root 0 -20 0 0 0 S 0.0 0.0 0:00.00 rpciod
282 root 20 0 0 0 0 S 0.0 0.0 0:00.60 kworker/0:1
293 root 20 0 0 0 0 S 0.0 0.0 0:00.29 kswapd0
294 root 20 0 0 0 0 S 0.0 0.0 0:00.00 fsnotify_mark
295 root 0 -20 0 0 0 S 0.0 0.0 0:00.00 nfsiod
296 root 0 -20 0 0 0 S 0.0 0.0 0:00.00 crypto
334 root 20 0 0 0 0 S 0.0 0.0 0:00.18 scsi_eh_0
337 root 20 0 0 0 0 S 0.0 0.0 0:00.00 scsi_eh_1
340 root 20 0 0 0 0 S 0.0 0.0 0:00.01 kworker/u:2
341 root 20 0 0 0 0 S 0.0 0.0 0:00.07 kworker/u:3
351 root 0 -20 0 0 0 S 0.0 0.0 0:00.00 comcerto_spi.1
353 root 0 -20 0 0 0 S 0.0 0.0 0:00.00 comcerto_spi.0
386 root -2 0 0 0 0 D 0.0 0.0 0:00.20 btn_t
403 root -2 0 0 0 0 S 0.0 0.0 0:00.00 a3gblink_t
418 root 20 0 0 0 0 S 0.0 0.0 0:00.00 scsi_eh_2
419 root 20 0 0 0 0 S 0.0 0.0 0:02.74 usb-storage
436 root 20 0 0 0 0 S 0.0 0.0 0:00.22 kworker/1:2
450 root 20 0 0 0 0 S 0.0 0.0 0:00.15 md1_raid1
452 root 20 0 0 0 0 S 0.0 0.0 0:00.06 kjournald
2087 root 20 0 4160 1280 1216 S 0.0 0.6 0:00.38 udevd
2554 root 20 0 4096 1152 1088 S 0.0 0.5 0:00.02 udevd
2555 root 20 0 4096 1088 1024 S 0.0 0.5 0:00.00 udevd
4140 root 20 0 3328 1600 1216 S 0.0 0.7 0:00.04 rpcbind
4413 root 20 0 5120 704 640 S 0.0 0.3 0:00.00 dhclient
4659 root 20 0 32384 2816 1728 S 0.0 1.2 0:00.38 rsyslogd
4745 root 20 0 57088 3968 2688 S 0.0 1.7 0:01.02 apache2
4772 root 20 0 3264 1408 960 S 0.0 0.6 0:00.01 mdadm
5213 root 20 0 0 0 0 S 0.0 0.0 0:00.01 jbd2/sda4-8
5230 root 20 0 71232 2496 1280 S 0.0 1.1 0:00.46 upnp_nas_device
5243 root 0 -20 0 0 0 S 0.0 0.0 0:00.00 ext4-dio-unwrit
5908 root 20 0 2112 1216 960 S 0.0 0.5 0:00.09 ifplugd
5952 root 20 0 1920 768 704 S 0.0 0.3 0:00.01 wd-btnd
6301 root 20 0 3520 1536 1088 S 0.0 0.7 0:00.06 cron
6572 root 20 0 0 0 0 S 0.0 0.0 0:00.02 knetatop

The error message that a]you are getting is because you don’t have a stop for restsdk-serverd in your user-start file. Not sure why these processes are running. I’m assuming that the file user-start has 777 as its permissions. IF your not sure what that means . use the command ls -l /CacheVolume/user-start. It should show
-rwxrwxrw- 1 root root 892 Nov 9 18:04 /CacheVolume/user-start

The only other thing I see is that my entries are sorted low to high. I don’t think this would make a difference. But try it.
#/etc/rc2.d/S01motd
#/etc/rc2.d/S01wdAppEntry
/etc/rc2.d/S03atop stop
#/etc/rc2.d/S04apache2
#/etc/rc2.d/S16ntpdate
#/etc/rc2.d/S16openvpn
#/etc/rc2.d/S16ssh
#/etc/rc2.d/S17monitorTemperature
#/etc/rc2.d/S18monitorio
#/etc/rc2.d/S20minidlna
/etc/rc2.d/S20nfs-common stop
/etc/rc2.d/S20nfs-kernel-server stop
/etc/rc2.d/S20restsdk-serverd stop
#/etc/rc2.d/S20samba
#/etc/rc2.d/S20sysstat
#/etc/rc2.d/S20vsftpd
/etc/rc2.d/S20winbind stop
/etc/rc2.d/S50netatalk stop
/etc/rc2.d/S60mDNSResponder stop
/etc/rc2.d/S61upnp_nas stop
#/etc/rc2.d/S75sudo
#/etc/rc2.d/S84itunes
/etc/rc2.d/S85twonky stop

RAC

2 Likes

In this post it says the file s/b called user-script.

That is what I called mine. I guess it s/b called user-start?

Hopefully it was my permissions. I just ran this and now hopefully my script will run.

VMC4T:/CacheVolume# ls -l user-start
-rw-rw-rw- 1 root root 366 Dec 7 10:50 user-start
VMC4T:/CacheVolume# chmod 777 user-start
VMC4T:/CacheVolume# ls -l user-start
-rwxrwxrwx 1 root root 366 Dec 7 10:50 user-start
VMC4T:/CacheVolume#

Is there a way to test the user-start script w/o a reboot?

The easiest way is to sh /etc/rc2.d/S98user-start

RAC

1 Like

That worked! Thanks.

I think I need to let Netatalk stay running since I occasionally use a MAC. Then add a stop for restsdk-server.

Here are my results:

VMC4T:~# sh /etc/rc2.d/S98user-start
[ ok ] Stopping wdmcserver: wdmcserver.
[ ok ] Stopping wdphotodbmerger: wdphotodbmerger.
[ ok ] Stopping wdnotifier: wdnotifier.
[ ok ] Stopping the Winbind daemon: winbind.
/etc/rc2.d/S98user-start: line 5: /etc/rc2.d/S20minidlna: No such file or directory
PID file /var/run/mediaserver.pid not found, stopping server anyway…
twonkystarter: no process found

Stopping Netatalk Daemons: afpd.
[ ok ] Stopping mDNSResponder: mDNSResponder.
[ ok ] Stopping wdAutoMounter:.
[ ok ] Stopping NFS common utilities:.
[ ok ] Stopping NFS kernel daemon: mountd nfsd.
[ ok ] Unexporting directories for NFS kernel daemon…
[…] Stopping upnp nas device: upnpnasdNo process in pidfile ‘/var/run/upnp_nasd.pid’ found running; none killed.
failed!
VMC4T:~#

I have the same issue, ever since I upgraded my firmware to the latest, my MyCloud hardly sleeps and keeps thrashing the disk and blue light remains solid. Prior to the firmware update it was sleeping regularly after approx. 10mins. I have a 3TB model. I’ve attached the processes running on my drive. I’ve now stopped the restsdk-server process and the wdnotifier service. But it continues to thrash away. I didn’t want to stop the wdmcserver service as that removes the thumbnails. I’ve resorted to disable remote access to see if that makes a difference so I will check the drive soon. Ideally I would like to have remote access to the drive to download and upload files on the go.

Can anyone suggest anything else to try? I’ve done a system reset many times during my testing.

Yes, disable both the wdmcserverd-and-wdphotodbmergerd services even though you don’t want to do so. Disabling both of those services appear to help some. This sleep issue is a problem that has gone unaddressed by WD since they introduced the OS 3 firmware a few months ago. There are several other threads complaining about the issue.

https://community.wd.com/t/how-to-permanently-disable-wdmcserverd-and-wdphotodbmergerd/135878

Thanks for your reply. I’ve got more insight into this issue on these posts.

On a separate note, WD Support is terrible imo, I’ve been left in limbo/abandoned despite having a case open with them and no one from WD Support is responding back to my query.