Drive Sleep

The latest release keeps my drive spinning without sleeping. I’ve tried everything I know via ssh to stop processes that could write to the disk. HEY WD - HELP !!!

Can you check the drive spinning because your unit is re-indexing your files.

You should check your /var/log/user.log for the following error messages:
2015-10-11T14:03:16.944447-04:00 di=TCG2w1CF6F notice restsdk[6105]: paths.go:43: Could not dial crawler socket at
‘/tmp/WDMCRequest.socket’, error: dial unix /tmp/WDMCRequest.socket: connect: connection refused
2015-10-11T14:03:18.011865-04:00 di=TCG2w1CF6F notice restsdk[6105]: watch.go:109: Stat(), error: stat /tmp/dynamic
config.ini: no such file or directory
If you see these error you need to go to /etc/rc2.d and sh S20restsdk-serverd stop
The restsdk process sometimes writes these error messages every 10 seconds.


I have checked the user log and I don’t see any error stuff causing the disk to not sleep. I stopped the restsdsk and the wdmcserverd and the wdphotodbmanagerd and that helps until the next time I access to disk. Then it stays awake until I reboot and kills ht processes again.

I just updated to the latest firmware .112 and I will see of it helps.

Try doing a grep exit /var/log/user.log. This will show you every time the system woke up. It will also show you the sleep time.


I will the next time it does not sleep. I upgraded to the latest firmware and so far (without any intervention) it has gone to sleep.

Well I get a lot of exits from the user.log

2015-10-23T09:01:21.105640-04:00 di=fCsfuU9oQi notice logger: exit standby after 359 (since 2015-10-23 08:55:22.340671000 -0400)

So how do I see what’s causing it?

Your supposed to get the exits. Its the value following the word after that is important. Its is the number of seconds that the drive was in standby. You would like to see values greater than 3600. Which is one hour. The times will also depend on what you are doing with the device. I let mine sit for a 24 hour period and then check the sleep times. You can do a tail -80 /var/log/user.log to get the last 80 entries in the log. Which should be mostly exits.
Also try a mount command. Let me know what the values are for the root file system. Also you should show more exit lines.


I had the same problem where my 4TB My Cloud wouldn’t sleep and I had a ton of these “dynamicconfig.ini” entries in the log after upgrading to V04.04.01-112.

BTW, for anyone nervous about using SSH, I just retrieved the logs via the http://wdmycloud dashboard. You just need to click the Question mark at the top of the page, then Support, then click the “Create and Save” System Report button. After a couple of minutes, you’ll get prompted to save a zip file and you’ll find the user.log file buried in there.

Anyway… I simply ran a System Factory Restore (System Only) and the “dynamicconfig.ini” log errors stopped and my device now sleeps properly.

Do you have remote access enabled? The error messages seem to be related to
remote access being disabled.


I let mine sit for a 24 hour period and then check the sleep times.

I suspect that any devices that are ‘connected’ to the MyCloud, such as media players or computers (of any sort) that have a file service connection to the cloud can cause it not to sleep, due to them mucking about when you’re not actually ‘doing anything’ with them. And things like tablets and phones aren’t really ‘off’ when in sleep, and can still be wurbling away in the background…

So if you want to investigate if the MyCloud itself is waking itself up, I think you need to break all network connections to it, either by unmounting all remote drive access, or by powering down all client devices. And, if your house is like mine, there will be quite a few devices to turn off (PC, one iPad, 3 Android tablets, one Android media box, one media renderer, ermm is that the lot…?).

Then there’s remote user access…

In my investigation of sleep issues. I’ve had the My Cloud only wake up at 03:00AM every day. Which is when the device wakes up to do house keeping. Since firmware 303 the device wakes up more often to do house keeping. Atop wakes up every 8 hours to rotate logs. These are my sleep times. As best as I can tell all of those wake times were scheduled by the My Cloud OS.
10 29 23:23:42 23:23:50 8 0:00:08
10 29 23:34:01 23:37:47 226 0:03:46
10 30 23:47:59 00:01:12 793 0:13:13
10 30 00:11:24 00:30:11 1127 0:18:47
10 30 00:40:23 00:40:31 8 0:00:08
10 30 00:50:43 01:10:35 1192 0:19:52
10 30 01:20:47 03:00:12 5965 1:39:25
10 30 03:15:24 03:15:32 8 0:00:08
10 30 03:25:44 03:38:54 790 0:13:10
10 30 03:49:06 03:54:52 346 0:05:46
10 30 04:05:05 04:05:12 7 0:00:07
10 30 04:15:24 04:17:11 107 0:01:47
10 30 04:27:23 08:01:10 12827 3:33:47
10 30 08:11:23 08:11:51 28 0:00:28
10 30 08:22:03 10:10:39 6516 1:48:36

PS I have two Samsung phones, a laptop,3 PC two running windows 10 and one running Debian Linux, A blueray player with streaming capability.

Thanks for the solution error “error: stat /tmp/dynamicconfig.ini:”
cd /etc/rc2.d
sh S20restsdk-serverd stop

seems to work.

Will i get the error again after reboot or is this setting now permanent?

It will happen every reboot.


rac8006, you are right. I did some experimenting and as long as Remote Access=On, the device can sleep. If I disable Remote Access, it can still go to sleep. This seems to only last until the box is shutdown or restarted. In that case (where Remote Access=Off), the dynamicconfig.ini entries came back (every 10 seconds as before) once the system restarts. I can fix it by turning Remote Access back On or turning it On then Off.

So it appears that (for me) leaving Remote Access=On is a permanent fix and turning it on then off is a temporary fix.

Support is aware of this. But can’t seem to figure out how to fix it.