Updated to Win 8.1, now cannot map to MyBookLive 2TB. Permissions issue

After the 8.1 upgrade from 8, when I try to map to MyBookLive, I get a Windows Security prompt. No credentials I enter seem to work. After three tries I get a error message saying I do not have permission to access this location. Can’t figure this one out.

Can you access the My Book Live dashboard? You can also try mapping the My Book live using the WD Discovery app, check the link for the steps. 

Mapping a drive letter on a WD Network hard drive using WD Discovery

I have tried both methods without success. I suspect the issue lies with the OS and/or registry. I have My Book connected directly to my pc’s ethernet port because the router is wireless and in another room.

I can access the dashboard, however. Checked all share settings. Everything is the same as before the 8.1 upgrade when it was mapped.

thats fine localy but not remotely.

i am having the same issues. Now i cant even get passed the logon screen.

the problem began for me once i upgraded to internet explorer 11.
None of my pcs and surface pro will log on. even my work pc won’t logon to wd2go.Com.

however, i have two other pc’s, running win 7 with internet explorer 10. both allow me to logon and show my shares on the pc.
I decided to conduct an experiment. I updated internet explorer 10 to 11 on one pc.
sure enought i was not able to logon to wd2go. It just won’t go beyond the login page.

just curious, is your laptop running any other version of internet explorer besides 11?

the wd desktop app allows connectivity to my drives however it is lacking in features and not being able to map my shares to my remote pc’s makes it useless in my type of work enviroment.

before all this began, i was able to do the following with the wd mybooklive:

-My booklive is stationed at my home office.

-i have a share with my invoicing program file and outlook file in it.

upon completing services at remote locations, i was able to map that share to my surface and write up invoices localy on my surface which my invoicing program would access trought the shared folder on the mapped share.
This kept my invoicing up to date in all my stations, home, shop, and on the go, without me having to manually sync these files at every location.

i have tried every possibility. Nothing works. any browser i try, none work. So we might assume java might play a role in this. I apologize for not having some sort of solution or workaround for you but thats more than what wd has given their users for this problem.

it looks to me like wd needs to catch up to the new security implementations in java, or microsoft and other paid cloud services are in cahootz to bump this kind of equipment off the market so that users use their paid cloud services instead.

My book live and ex2 are now sitting on the shelve collecting dust and i’m back to using dropbox for these files, and microsoft’s onedrive for programs and utilities. both paid services.

 if anyone has a simple workaround to the above please let the community know. It will be greatly appreciated.

Hmm. I’m not sure your issues necessarily relate to mine. I simply want to be able to map to my drive, which is connected locally. Please don’t complicate this further. 

my apologies.