Updated to OSX 10.11.5 My Cloud unusable in Finder

I updated my MacBook to OSX 10.11.5 yesterday and not the My Cloud drive is basically unusable in Finder.
It is so slow and some folders never even show any contents.

I have rebooted the Mac, the router and the My Cloud drive and it’s the same. In the iOS app and on my Windows machine everything works fine.

I have the My Cloud pulling a static IP address and the way I connect on my Mac is to go to “Connect to a server” and use that address.

Don’t know if there is a good fix for the El Capitan issues. If you do a subforum search you’ll find numerous people having issues with El Capitan and the My Cloud. Here is one large thread where various issues are discussed with some workarounds that may or may not apply for your issue.


I do not use any of the WD software, so here is what works for me:

  • internet browser for dashboard access (http://my-devce-ip)
  • Windows File Explorer for accessing or map the share: \\my-devce-ip\
  • OS x Finder for accessing the share: Finder > Go > Connect to Server > smb://my-device-ip

You can also try it replacing my-device-ip by the name of the device.

I am a Mac user.

I’m having the exact same issue. Glad to hear I’m not alone.
I’m performing a check of the drives, but the issue was too immediate to the update and I’m quite certain something is wrong with it. I also tried some permission repair, but nothing.

Get used to do it this way all the time and all your problems will go away…

  • OS x Finder for accessing the share: Finder > Go > Connect to Server > smb://my-device-ip

That’s exactly how I always do, and always have done with WD products.
I like to use the nas with my account, not as a guest or similar.

Oh lol, I just noticed it goes way better if I use it as a guest.
Ok, starting to see a pattern here.
I’l do some troubleshooting later, trying some of the solutions I’m reading in the El Capitan thread, and post here if I find something useful.

??? Did you save save it to your keychain as guest?

I never select that option, and it always prompts me to enter a username or use guest. If you did save it, delete the keychain. You might also have to “eject” it first.

I get this all the time when I try my suggestion from earlier:

I didn’t. I simply tried an access by selecting the volume from the left bar of Finder.
That way grants the access as a guest.

That is exactly how I do it and it had been working fairly well until I updated my Mac’s OS to 10.11.5
Are you using 10.11.5 on your Mac, Shabuboy?

1 Like

Good point. No, I am on 10.11.4, sorry.

I’ve the same problem and I had to back to 10.11.4.

Same problem here.
Tried to connect using command + k with cifs:// or afp://, it works for me but the transfer speed are much much slower.

I get the following error when I try to move or copy files from my MacBook’s drive to WD MyCloud drive, using finder:

The Finder can’t complete the operation because some data in “name of file” can’t be read or written.
(Error code -36)

This is happening ever since I updated to 10.11.5 yesterday.


Based on what I read in that Apple Discussions thread I tried CIFS instead of SMB. It does work but it’s kind of slow.

In my case it doesn’t matter: CIFS and SMB are works very bad, it’s unusable.

Problem with using Go->Connect to Server when I mount a share its blank. If I use the left hand side of Finder and click the WdMyCloud and connect that way I see my files with proper permission.

A new firmware has been released but no mention of SMB or AFP or Finder issues. Also, PLEASE submit a feedback report to Apple. SMB is broken

Shabuboy doesn’t work for WD; none of us do.

You can report to Apple if you are having problems with your Apple product.

I can confirm I have the same issue, I thought it was because I had not updated to the latest mycloud firmware but updating did not fix the issue, I updated to osx 10.11.15 a few days about and since then using finder to access my share drives has been very slow and I receive the following error when I try to copy files to the shares “The Finder can’t complete the operation because some data in “name of file” can’t be read or written.
(Error code -36)”