Unlimited space on WD30EZRX drive and GPT issues

Hi there,

I’ve read a lot on this forum and I’m not sure if a similar issue was already handled. Please forgive me if so.

I’ve bought a WD30EZRX drive. Under windows, everything works fine, I can create a format partitions, read and write. But something caught my attention. When creating my partitions, I saw that the free (unallocated) space on the drive was 4 739 753 992.00Go which is just wow :D. Has somebody already experienced such a case ?

That would’nt be a problem if I could use it with other devices such like Pop-corn hour  (PCH) A-400 but I can’t. The PCH server log tought me that the disk was too big. There began my journey… I investigated with gdisk and parted under linux and saw that my GPT was broken. Everytime i tried to delete and recreate it, I had the same “broken” token. I therefore used the WD Lifeguard Diagnostics utility (Windows) but it could’nt access the SMART data (I’ve also tried with a linux utily and could’t access SMART data on a same fashion). I’ve finally filled up the drive with zeroes and recreated a partition of 2,8To on it + set the drive with a GPT using windows drive handler. Now the drive is detected by the PCH but for only 2 seconds before vanishing and being detected again endlessly.

I know it’s a kind complicated case but does it ring any bell to anybody ? I guess plenty of yours will say that the problem comes with the recent PCH and they will probably be right. Anyway the huge size and the hasardous handle of the partition table are not linked to any 3rd-party device.
According to you, should I send the drive back ? My drive is quite “old” now since I’ve bought it a year ago. Was there any firmware update in the mean time ? May it solve anything ? Where can i access it? (I did’nt find any on the WD30EZRX page of the WD website).

Thanks in advance & BR,


Edit : I use the drive as a external “cartridge” on a USB3.0 dock.


Does the PCH supports 3 TB drives? Have you tested with another drive with that capacity?

Actually, it does. At least, it used to support 3TB drives, since I could see/access a 3Tb. I tried with the same drive, formated with ext file system using the PCH to do so (as suggested in other posts of this forum), and it actually works. So I guess the support isn’t the problem. The problem with this solution is that the PCH creates 4 partitions and only 1 of these is usefull for an external drive. Therefore we lose several Gb because of that. The other problem is that my drive won’t be usefull as external drive when pluged directly on my computer under W7 (Windows and ext file system are’nt friends at all). For your perfect information, I tried to delete extra partitions created by the PCH and format the biggest remaining one with NTFS… but the only result was an undetectable drive for the PCH.

As mentionned before, I think the PCH was the way to discover my feeling of an existing problem was right. Therefore, I mostly would like to understand :

  • why my unallocated drive space is so huge and if this is normal
  • why destroying and rebuilding my GPT with several tools (parted, gdisk, windows disk handler, WD Data lifeguard) only gives a broken GPT

I had more or less the same problem…

bought TWO WD30EZRX, both made october 2012 same firmware and model number.

Formatted via WIN 7 in GPT in NTFS, via SATA cable, IN THE SAME EXACTLY WAY.

Inside the popcorn C-200 ( into the “hot swap bay” )one works, the second is not recognized!!!

( I checked and compared the two disk with windows 7; for CrystaldiskInfo under WIN 7 both are OK, SMART are OK, ALL is the SAME!!!)

Whe I insert the NOT working HD into C-200, appear a name SATA_DISK_A1_1. the good one has correct name SATA_DISK_A1

After few test NOTHING to do!!!

The day after one HD is completely DIED!! connected via SATA as second HD, WIN7 doesn’t START. The BIOS find the HD but WIN 7 stops before to start.

Via USB the HD is not find.

With DLGDIAG5.2 in DOS, in low level format deep analysys “TOO MANY ERRORS FIND…”

The HD has worked for 20 hours, I lost 3TB of data. WD replace with a RECERTIFICED DRIVER WITH ONLY 3 MOUNTHS OF GUARANTEE REMAIN TIME!!