WD30EFRX capacity not recognized

I have a WD30EFRX drive which is showing in windows only with as a drive with 746Gb capacity.

I’ve tried DISKPART to clean it, but the actual size is still not recognized.

I’ve tried several free partition managers, and tried to do a raw write, to no avail.
The wiper program did showed a total sector count of 1565565871

Status is that the drive has no partitions, and is not allocated and shows a max capacity of 746,52Gb
How can the drive be re-initialised from scratch and seen again with its original 3TB capacity?

I wonder if the WD Data Lifeguard Diagnostic for Windows would reset it…have you tried it?
There is also a diskpart cmd (clear-disk) when used with the proper command parameters will re-init it.

I run the program WD Data LifeGuard Diag (Quick Test, Erase), but no change.
Also tried the diskpart command (CLEAN), to no avail.

It keeps reporting 801,57GB.

I had also submitted an official ticket with WD Support a couple of days ago, but so far no response from them received

Did you use diskpart “clear all” command? Another thing you could try is download the MiniTool Partition Wizard and look at the drive to see the partitions. This program will also delete partitions and make new partitions. Also good for cloning a drive and it’s free.

Yes, i did a “clean all” from diskpart, and at the end the disksize number was down to 746,52GB
(ending LBA = 1565565871 - expect to be at 5860533168)
As to MiniTool Partition Wizard, there a no partitions seen anymore, as the disk has been cleaned.

I have the same problem, and I’ve tried the same steps to resolve the issue but no luck! Can it just be a defective drive?

So I also put in a ticket with WD support. They wanted the drive S/N and proof that I purchased it before they would do anything! I was very disappointed in their response to my problem since I didn’t have that stuff on hand at the time! Anyway I fixed the problem myself by simply using a different computer using Windows 10 to manage the drive. I was able to format it to its full capacity and re-installed it into my older Windows 7 desktop and it works fine now! I still don’t know what the fix would be for older operating systems though but at least I know that its not the drive that’s the problem. My question to WD support is why didn’t they just suggest that simple fix without the hassle of tracking down my Best Buy receipt and removing the computer cover to find the serial number? I know a lot about computer hardware but I’m no expert by any means!

The WD Data Lifeguard software will reveal the serial number. Just for future reference. (I edited my serial numbers out)


Thanks for the info, it’s just that I was talking to WD on my lunch break at work, not at my home computer.

Not knowing what kind of machine you are using the comments suggest a BIOS limitation typical for pre UEFI based machines.

It is an older machine, I put it together back in 2009 I think! But the BIOS did recognize the full 3TB when I checked, it seems it was just Windows 7 that didn’t! I did find online that Microsoft is still allowing the upgrade to Windows 10 from 7 for free but it will delete all my current programs, most of which just can’t be replaced because the manufacturer no longer supports them. In particular Autodesk Inventor Series, I paid a lot of money for that software and now they refuse any new licenses so it can’t be installed on a new drive!

As long as you have the installer you can reinstall Autodesk software as needed. I have lots of old software for Autodesk, Adobe and Corel. It all works fine.

A more modern machine can use 1/3 the power. My desktop with monitor etc all use 150W of power so this compares to my 2009 rig which used a lot more.

This new box pays for itself in power savings alone.

Here’s the response from Autodesk when I tried to re-activate my software on a new drive:

“On August 31st, 2019, Autodesk will end support for versions 2010 and earlier that have reached end of support and ask that you upgrade to a supported version.** You can continue to use your product if you already have it installed, but we will no longer provide support, including re-activation, for these versions.”

I use the 2009 version because that’s the last one that included Mechanical Desktop! I have all the original software, I just can’t get an activation key online!

if the software does not activate, you have possible legal rememdy, perpetual use means perpetual

windows xp is not supported but it activates fine