Unbricking WD Mycloud gen 2. SOLVED!

I have used wdmc gen2 3TB for year and half. And im trying to turn it to Debian Clean OS by follow fox-exe’s tutorial. And it’s success. Few days after im decide to uninstall OMV. And it’s makes my WDMC turn brick. It just shows blinking red light. can’t telnet and can’t access SSH too.

I thoughts it’s not a big deal. and im teardown WDMC and link this hard drive to my computer. and repart everything via linux terminal. 1GB sda1 for swap, 20GB sda3 for rootfs, sda2 for all rest space (actually this hard drive shows on my computer sdb anyway).

> parted /dev/sdb
> rm 1
> rm 2
> rm 3
> mkpart primary 0% 1G
> mkpart primary 21G 100%
> mkpart primary 1G 21G
> q
> mkfs.swap sdb1
> mkfs.ext4 sdb2
> mkfs.ext4 sdb3

Unpack jessie-rootfs.tar.gz to sdb3. and places uImage and uRamdisk into /boot/. I think this is no problem. because what fox-exe debian tutorial does is just like this. But im FAIL. it blinking red light agian. Im start thinking maybe sdb3 must be 4G? And i did repart. and FAIL again.

After lot of research. I decide to unbrick official way. following _Unbricking_en.txt. And this time router finally shows WD Mycloud. and access web GUI. But when i upload firmware(.bin file) it stucks on 0% forever. press F12 shows error that:

XML Parsing Error: no root element found
Line Number 1, Column 1:

I just don’t know what i am doing wrong. i found some of people faced problems like me. And they are not solve these problems too (at least threads shows they are not). did anyone faced problems recently like me ? did u solve this ? How ? please leave a comment. let us figure it out.

Suddently i found images of WD Mycloud’s parts. and do recover via linux. PROBLEM NAILD! Just remember if you stuck on 0% while uploading firmware. Just do this:

First. make parts following commands.

#change the sdB for the letter of your disk. Ex sdA,sdB,sdC… (List disks in system: “parted -l”)

parted /dev/sdb
    mklabel gpt
    mkpart primary 1049kB 2149MB
    mkpart primary 8591MB -1MB
    mkpart primary 7517MB 8591MB
    mkpart primary 2149MB 3222MB
    mkpart primary 3222MB 4296MB
    mkpart primary 4296MB 6443MB
    mkpart primary 6443MB 7517MB


    mkswap /dev/sdb1
    mkfs.ext4 /dev/sdb2

And doing recover from Images of this: Oops!.

apt install gem
gem install yadisk
mkdir /mnt/tmp
mount /dev/sdb2 /mnt/tmp
cd /mnt/tmp
yadisk https://yadi.sk/d/J9iDSf4TqQeZ4
unzip WD.zip

#change the “/mnt/tmp/” for the path to your files

dd if=/mnt/tmp/sdb3.img of=/dev/sdb3
dd if=/mnt/tmp/sdb4.img of=/dev/sdb4
dd if=/mnt/tmp/sdb5.img of=/dev/sdb5
dd if=/mnt/tmp/sdb6.img of=/dev/sdb6
dd if=/mnt/tmp/sdb7.img of=/dev/sdb7

That’s all ! It works. it bring my WDMC alive! And now i need to figure out how the clean debian bricked my WDMC and why the heck can’t recover the way of fox-exe.

And sorry for my excellent english. LOL

1 Like

Hello, I have same problem. dd function solves, but only until first reboot. Then Volume_1 is missing

The data volume 1 on the drive is not accessible. Contact WD Support.

Wow finally a tutorial that works! i tried many time the fox-exe tutorial, but the result was always a flashing red-LED.

Now, first try with this tutorial, and it works! I got the blue stable led and can open the web-gui.
Next Problem is, that no space is available and the factory-reset in settings is not available. But i’m sure i can figure it out

ok i failed… web-gui shows me no space… i cant format… and something is wrong with the drive
can someone help? got the 4TB gen2

If you haven’t done so already, try doing a System Only Restore via the Settings Utilities page.

If that doesn’t work you may have to try the restore process a second (or third) time. It is not uncommon to have to try the unbrick process a couple of times to get it to work properly. Unfortunately if the restore steps are not followed exactly one can have issues. When partitioning the drive, do not adjust the values, use the exact values in the unbrick directions.

Just wanted to post this here incase it was useful for anyone. I was also able to access the MyCloud device after following the instructions, and the dashboard indicated that there was no space on the hard drive as posted here previously.

Immediately when logging into the MyCloud via its IP address, I would land at a screen asking to setup a RAID device. I started that process, chose the JBOD option (which was the only one present), and completed the formatting. The progress bar stayed stuck at 0% for me but I waited it out and did something else in the meantime. When I came back around 20 minutes later, I saw that the hard drive formatting was completed successfully, and the dashboard indicated that I had free space available close to the entire capacity of my new hard drive (which is around 3.89TB out of 4TB).

The other fox-exe tutorial was unsuccessful for me but this one was the key for getting my device to work with a new hard drive. I did several firmware upgrades after the RAID formatting and everything is working for me including cloud access.

Thanks and good luck.

now i solved my problem for my 4TB gen2: i did again the steps vom post#1 and some more:

  1. took a laptop,
  2. a usb to HDD adapter
  3. usb stick (fat32) with the img-files(sdb3-7.img)
  4. and a usb stick with ubuntu live

plug everything into the laptop, started ubuntu live,
find out which label my devices are with gparted or command parted -l (ex. my WD-HDD is ‘sda’, usb stick with img-files is ‘sdc’)
Started with this:

parted /dev/sda
mklabel gpt
mkpart primary 1049kB 2149MB
mkpart primary 8591MB -1MB
mkpart primary 7517MB 8591MB
mkpart primary 2149MB 3222MB
mkpart primary 3222MB 4296MB
mkpart primary 4296MB 6443MB
mkpart primary 6443MB 7517MB
mkswap /dev/sda1
mkfs.ext4 /dev/sda2

mkdir /mnt/usb
mount /dev/sdc1 /mnt/usb
dd if=/mnt/usb/sdb3.img of=/dev/sda3
dd if=/mnt/usb/sdb4.img of=/dev/sda4
dd if=/mnt/usb/sdb5.img of=/dev/sda5
dd if=/mnt/usb/sdb6.img of=/dev/sda6
dd if=/mnt/usb/sdb7.img of=/dev/sda7

then plug out the HDD, put it into WDMC Board and start it.
the Web GUI shows up, click through the first steps, and the RAID (JBOD) thing doesnt work, and there is no available space.
Then go to settings-tab, > helptool (in german hilfsprogramme) > “quicktest”
after that click on restore “only system”… wait… WD will reboot.
After that the raid/jbod thing will work an WD will format the HDD.
wait… FINISH!