Unable to stream media using twonkly service

I have a new mybooklive updated to the latest firmware and am trying to stream my video and music files to a WDTV Live (connected to a Philips TV) and direct to a Samsung TV

I have set up the mybooklive for streaming, Twonky (5.1.9) enabled, it sees my devices and their IP addresses, none of which are blocked and that there are 4 video files listed in the database and 19 music tracks.

However even though both TV and WDTV Live can see the twonky DNLA server they say no shared files available. I assume that as soon as the files show up under status in the media tab og the dashboard they should be available for streaming?

I can however view and play the files on the WDTV Live using network shares, the TV doesnt allow this so media streaming is the only option

I have reset and rebooted and power cycled all devices. I bought the mybooklive for streaming to replace the system I currently use which is a USB drive attached to my Netgear router which has DNLA cabalitlites. That works OK but is slow and cumbersome so I thought mybooklive would be faster and I could use it to back up my computers too. My current system streams the files in question no problem and they play fine. Any ideas why the mybooklive cannot do this?

thanks Barry


PS According to the Twonky website both the TV and WDTV Live are compatible with their server.

After a day of frustration and then a good nights sleep I decided to start again. Rebooted/reinitialised everything, turned off the Twonky server and deleted the default shares. Created the shares anew, started the twonky server and it sprang into life. Now, not just my WMP12, but both my TV and WDTV Live see the Twonky streaming files. But why, who knows… Plug and almost play

I have the same problem. The answers from the WD helpdesk did help me with finding a solution. What exactly did you do to solve your problem? How did you delete the default shares when your Twonky Server was turned off? (I can’t access mybooklive:9000 after disabling Twonky Server in the MyBookLive dashboard).

In the MBL UI under shares I just turned off media serving of all shares, set them to none. I then created my own shares, turned on media serving for those folders, then enabled Twonky and it worked. Has worked ever since.