Unable to restore Time Machine backup from WD MyCloud Home

Hi all,

I’ve made a backup to the Time Machine on my WD MyCloud Home. It’s saved as per below under “Guest” and I can see and access it on the network via my computer. Image here: https://imgur.com/a/qO5LX

However, when I tried to restore it via the Time Capsule, it’s saying that a login/password is required. I have tried every login I could think of and none is working. This shouldn’t be the case as it’s stored under “Guest” but I can’t seem to get around this page. Image here: https://imgur.com/a/r53Fl

As an alternative, I’ve also tried copying the Time Capsule backup to another external hard drive, but I keep getting the error of “insufficient permissions” half way through copying the disk image.

I’m really out of options at the moment - been on customer support with WD and still can’t find a solution!

Cheers

Hi passengerplane,

Have you tried your dashboard credentials to authenticate?
Try with the Username and password you have on your my cloud admin’s account to authenticate.

I have the same issue, I’ve tried my registered user login, this doesn’t work.

I would expect that you should be able to access as Guest, especially if this is the only way to setup time machine.

Has anyone managed to solve this?

Hey, I’m having the same problem. Did you guys find a solution?

1 Like

I figured out how to do it.

Install Mac OS X first then during the initial set up you can restore from a Time Machine backup and it lets you login to the My Cloud Home as Guest which it does not let you do when you try to restore from the Time Machine backup in recovery.

1 Like