Unable to obtain IP address

I’ve been using the WD TV Live Hub (1TB) for ~9 months.  It has worked great up until a few days ago when it suddenly dropped off the network.  Now it won’t even get an IP address from the router.

I’ve eliminated all variables between the router and the WD device - It is now wired directly to my router in the closet.  All other networked devices (laptops/Wii/printers/etc) are working fine. I’ve tried multiple ports on the router. 

I’m stumped.  Any suggestions would be greatly appreciate.

Are the Ethernet LEDs lit?

Thanks for the response.  Yes, LEDs are on. 

Router LED shows the port is active.  The ethernet port on the back of the WD shows both LEDs working as well (solid green on the left side of the jack and blinking yellow on the right — hmmm, should the right blink yellow or should it blink green?)

That’s the correct color and behavior…

You might try doing a full reset to factory defaults?

Reset worked.  Many thanks for the help!

My pleasure.  Glad it worked. :slight_smile: