Unable to obtain IP address - Buffalo WLI-UC-GN/Linksys WRT54G


#1

WDTV Live, latest firmware installed using Bufallo WLI-UC-GN.on a Linksys WRT54G router (DD-WRT)

The adapter powers on, I’m given the choice to connect to a wireless network, but no matter what I do I always get an error message saying it can’t obtain an IP address. 

I tried entering manual settings: 

192.168.1.5

255.255.255.0

192.168.1.1

192.168.1.1

The settings were accepted and it said that everything was OK, but when I ran the test it stalled at the DNS test.

Thanks for any help.


#2

It may be that you’re not actually successfully associating with the wireless hub.

It will fail those tests if that’s the case.

Make sure the Wireless Security settings match.


#3

How can I modify the security settings? I was never given the option to.


#4

chimaera15 wrote:

How can I modify the security settings? I was never given the option to.

If your Wireless is completely “Open,” (meaning unsecured) then it won’t ask you for any settings other than MANUAL or AUTOMATIC IP configuration.

However, if it’s secured (and it really should be unless you leave out in 10 acres with no neighbors), then there’s two possibilities:

 You are BROADCASTING your SSID:   The WDTV will either ask you for a Security Key or a User ID and password.

  If you’re NOT broadcasting your SSID, the WDTV will first ask you to provide the SSID (or network name) you want to connect to, followed by what security type is being used, and then ask you for the key, userid, password.

As to WHAT it asks you for, it’s all dependent on how you have your Wireless Network configured in your Router / AP, or whatever is providing WLAN services.


#5

Just a quick addition:

Are you running MAC address filtering on the router?  

That can be a bit of a “gotcha” when setting up a wireless adapter the first time.  

You need to add the wireless adapter’s MAC address ( not the WD TV’s) to the router’s safe list.