Wireless set-up help

Ok. So I had trouble setting up my wireless connection on a secure network. So for years my router was set-up as an open network without broadcasting the SSID. This setup allowed me to connect the WD Live TV Hub to my wi-fi network and access my NAS and the internet. A firmware update eventually brought the whole thing down so I downgraded back to the previous firmware.

It was time to upgrade my router and setup a secure wifi network. Linksys E4200 setup with WPA2 personal - the ssid is now broadcast. The NAS has been trashed and replaced with a 1TB USB drive connected to the router’s usb port.

I upgraded WD firmware to 3.08.14.

Network setup on the WD sees the wireless network. Password accepted, chosing automatic connection gets me an IP adress  but checking connection shows no DNS and no internet. Device shows as connected on the router - appears as online in the device list using smart wifi and on the router’s diagnostics page:

DHCP Client list.JPG

 but unable to access the WD from any other device on the network. Automatic connection gives me gateway as and DNS as same.

from the router’s diagnostics page:

Router Information  Linksys Smart Wi-Fi Services  Internet Connection (IPv4)  Internet Connection (IPv6)  Local Network  DHCP Server  2.4 GHz Wireless Network  5 GHz Wireless Network  

Firmware Version:
Serial Number: 01C15608200604
Current Router Time: Friday, 08 March 2013 13:01:34 (GMT -05:00)
Current Browser Time: Friday, 08 March 2013 13:01:37 (GMT -05:00)
Internet MAC Address: C8:D7:19:0F:6B:XX
Server Name: CapotePas
Host Name: CapotePas
Domain Name: ae.cgocable.ca
Status: Connected
Connection Type: Automatic Configuration - DHCP
Internet Address:
Subnet Mask:
Default Gateway:
MTU: Auto
DHCP Lease Time: 2880 Minutes
Connection Type: Connecting
Internet Address:
Default Gateway:
DHCP Lease Time:
Local MAC Address: C8:D7:19:0F:6B:XX
IPv4 Address:
IPv4 Subnet Mask:
IPv6 Link-Local Address: fe80:0000:0000:0000:cad7:19ff:fe0f:6bb8
Prefix Address:
DHCP Server: Enabled
Start IP Address:
End IP Address:
Client lease time: 1440 Minutes
Static DNS 1:
Static DNS 2:
Static DNS 3:
Status: Enabled
MAC Address: C8:D7:19:0F:6B:XX
Mode: 802.11bgn
Network Name (SSID): CapotePas
Channel Width: Auto
Channel: Auto
Security: WPA2 Personal
Status: Enabled
MAC Address: C8:D7:19:0F:6B:BB
Mode: 802.11an
Network Name (SSID): CapotePas
Channel Width: Auto
Channel: Auto
Security: WPA2 Personal

So I try again with manual connection and setting gateway to and DNS to which still leaves my with an IP adress with no DNS, no internet when I check connection on the WD. But this time with a message that says “incorrect DNS server address. Please check your network settings and try again”.

Try again, this time gateway but with DNS same result, without the message.

I’ve checked the forums without success.

The wireless network adapter id DLINK DWA-160A2, H/W ver. A2, F/W. ver. 1.6

Any thoughts, suggestions, guidance of any sort is appreciated at this point. I can’t go back to an unsecured wireless network.

 UPDATE: upgraded the firmware on the usb dongle (DWA-160) to FW 1.80. Set router channel to 1. Reset the WDTV. At internet setup, resulting message says “congrats, you are now connected to the internet”… NOT!   Check connection still shows 2 red X for DNS and internet.

UPDATE 2: There is some communication, but no internet and c’ant access on the network.

Router log:

DHCP client log LAN IP address | MAC address | Timestamp | Message type F0:7D:68:F7:63:3D 2013-03-09T18:13:31Z Ack F0:7D:68:F7:63:3D 2013-03-09T18:13:31Z F0:7D:68:F7:63:3D 2013-03-09T18:13:31Z Offer
undefined F0:7D:68:F7:63:3D 2013-03-09T18:13:31Z Discover F0:7D:68:F7:63:3D 2013-03-09T18:13:30Z Offer
undefined F0:7D:68:F7:63:3D 2013-03-09T18:13:30Z Discover


Well, no help or answers yet… I guess I might conclude this is impossible.

I resorted to a work-around: I got my hands on an unused Linksys WRT-N400 router which I flashed with DD-WRT firmware and followed instruction on the DD-wrt wiki to set it up in client-bridged mode. Then I just cabled it to the WDTV and VOILÀ - worked on the first try. 

Still, can’t figure out why I can’t connect the WDTV to the E4200’s wireless network using a usb wifi adapter approved by WD. I suspect that it has to do with the WPA2 /personal security. Maybe the issue somewhere in these encryption protocols. I’m guessing since I could connect the WDTV over wifi when my wireless network was set-up with no security.

Although I’ve found a work arround solution using a second router   my question remains: if anyone out there has a WDTV Live Hub connected to the Linsys E4200 over a secure wireless network, I want to here from you.

1 Like

Anything inside your network (ie after your router) should have as its gateway, your router’s IP address.  In this case that would mean gateway= instead of  DNS would be as well.  Sounds like you got it working though.  I too use a dd-wrt hacked router as a wireless bridge to connect my WD Live TV Hub to my home network.  Knock on wood, works like a champ.

1 Like