Unable to connect to wifi

Hi guys

I have a WD tv live and since i have bought it it always had an issue with connecting to my home wifi. When i try and connect to the wifi automatically and put in the passkey its tries to connect and fails. I use netgear router and it came withWPA-PSK T KIP encryption. I have also tried manual configuration as well but it has failed as well. The values i have used for the ip and rest are as follows

IP: 10.1.1.4

subnetmask: 255.255.255.0

default gateway: 10.1.1.1  (this is default gateway shown in my laptop when I initiated ipconfig command)

DNS: 10.1.1.1

When i use these values the device tries to connect and comes with with a notification that the device couldnt connect to the network due to limited or no connectivity.

I have also tried to update the firmware since its running 1.02.21 but unfortunately when i downloaded and extracted the firmware to a clean usb key it wont update from the usb. It states that it need internet connection to update the device to the latest firmware.

can someone please help me in fixing these issue because i am unable to make full use of the device.

Thanks

Updating the firmware via USB does NOT require the internet.   It should just pop up a notification that New Firmware is available as soon as it detects the USB.

If that is NOT happening, and you’re instead trying to use the MENU to do it (which DOES require the internet), then the files you have on the USB are not the correct files.

If your NetGear is BROADCASTING its SSID, you should not have to select the security type.   It should be automatic, and all you have to provide is the password.

If your NG is NOT broadcasting, and you have to actually key-in the SSID, then there’s probably a mismatch in the security type.

But, it might not be either issue…  There have been other users report that they weren’t able to connect the WDTV via WiFi to a NetGear router… replacing the router fixed the issue.