Unable to connect remotely via www.wd2go.com

I have been trying to access MyCloud NAS via www.wd2go.com, but it has never worked.

I am using Google chrome and I always get the same old message:

Untitled.jpg

Tried clicking the link “Proceed to wdmycloud.deviceXXXX.wd2go.com” but i always end up at  http://info.singtel.com/personal/internet/addons/family-protection/detail

I am able to access remote via Android MyCloud app. Can someone assist?

No direct experience myself - possibly try FireFox?

Tired google chrome, IE and fire fox, none of them working

have you tried https://www.wd2go.com instead?

(having said that my IE and firefox automatically switch to secure connection if I miss http/https).

the second message looks like there is a web filter somewhere. For example, to  protect my children, I switch on family protection with my provider (I just login to my account with my provider and switch it on and off). This filters out illegal.unsecure sites etc… but sometimes a legitimate site might be caught as well. Do you have such a setting with your provider?

note: assuming remote access is conifgured properly on your wdmycloud.

Yes, I tried https://www.wd2go.com on your advice but still it is not working.

I don’t think there is anything to do with web filtering. I first bought my WD MyCloud a couple of months ago. It was working for a couple of  days, able to access via website www.wd2go.com and Android MyCloud App. After a few days, device started to fail frequently, unable to log into dashboard etc. Sent it for RMA, received the replacement set. Have it configured. MyCloud app is working, but not access remotely via website.

WD Support please respond.