Can't access device remotely or locally from (temporary solved)

I have a 3TB wdmycloud and already installed correctly , where ftp and port forwarding is set up . wdmycloud locally accessible but can not be read from the outside . it is very frustrating . I tried and found that it looks like there is an error on the server of for those who want to run a remote device but still get the error cos of the lack of improvement of wd , maybe you can try this simple way .
1 . still login to, locally or remotely
2 . Choose the device you want to open
3 . When there is no response from wd site says "this webpage is not available " try to copy the url address that is listed in the address bar and replace several lines of sections with your public IP address  (you can find it in or you local WD IP if you wan to connect locally
example :
https://xxxxxx.device13xx55.wd2go(dot)com/LandingPage?deviceUserId= 70xxxx85deviceUserAuthCode= 47a5b65c470xxxxxxxxxfd4476bc741

replaced the first address until /LandingPage by : /LandingPage?DeviceUserId=70xxxx85&deviceUserAuthCode=47a5b65c470xxxxxxxxxfd4476bc741
where is your public IP (or local WD IP if you can’t access from your network)


so maybe this is the simple way to make your WD act like a data cloud, until WD team fixes trouble in their ddns management system in

Hi ucitea, thank you for sharing, all remote access issues should be fixed by now. I recommend you to contact tech support for assistance.