New My Cloud - Unable to Access Remotely

I recently bought the standard My Cloud and set it up fine. I have selected remote access in the settings but I can’t login to mycloud.com when away from home and instead only get the “loading…” page before it times out. Shared links don’t work either.

I can access the mobile apps fine but from other computers/phones the links and mycloud.com don’t work.

Have I missed something obvious?

Hi, when you mention that you are unable to log in, are you meaning that after putting in the email and password you are receiving that error?

I’ve discovered a bit more.

It turns out I can access the site and shared link on mobile okay after all.

On my home network I can access both on Chrome desktop and mobile fine.

But on my work computer I can’t access it on any browser. I can access it on mobile on the wifi there though. Maybe it’s blocked by their firewall but I doubt it. They don’t block any sites there.

What happens is… I log in and I get the “loading…” page then a “can’t connect to My Cloud” page.
I noticed it does this when I’m using an ad blocker but I deactivated that and it still doesn’t work. I’ve tried Chrome, Firefox and Internet Explorer.

Any ideas?

Hello,

From your home computer:

From your work computer

  • Copy and past your external IP into your browser.

  • Open a command prompt and type nslookup to get your PC DNS server IP

  • Now check the following to see if anything fails

              nslookup  wdc.com  
              nslookup mycloud.com
              nslookup wd2go.com
    
              tracert wdc.com  
              tracert mycloud.com
              tracert wd2go.com

Hi,

All of them are timing out unfortunately. Any ideas?

Hello,

This means that your work PC DNS Servers, Routers or Network cannot resolve the mycloud.com domains. You’ll need to contact your place of employments System Admin, IT Staff or ISP to address this issue.

That is unfortunate. Oh well. Thanks for the guide, I’d have been frustrated for a while until I got bored trying to work it out otherwise.