Unable to Configure Plex Media Server on WDPR4100 mycloud OS 5

Hi There,
I have updated my WD PR4100 NAS to the latest firmware 5.11.112 and I am trying to configure Plex media server but I am getting stuck on the configuration section.
I have installed the latest Plex media server (PlexMediaServer-1.22.1.4275-48e10484b-MyCloudPR4100_OS5.bin) but when I click configure it does redirect me to the web login, then I login with my plex account fine, when I click on “Add your media”, it keeps asking me to “Get plex media server” See attached screenshot. the link shows the NAS IP address as it should.

I am confused and don’t know how to proceed. I was wondering if anyone else is experiencing this issue. Thank you very much in advance.
Kind Regards,

Hello,

Please refer to the following KBA article: http://support-en.wd.com/app/answers/detail/a_id/19636/

Hello

I followed the guides in detail but nothing is really changing for me. I get always the same as per the screenshot from the first post
I have installed/unistalled Plex from my PR4100 - rebooted, stopped and started the app in all sort of permutations

Enabled SSH

tried but unable to delete using the commands (unfortunately outside of my comfort zone although I’ve tried using Putty)

Any help is appreciated - would wipe the NAS entirely help?