Unable to access MyCloud Wirelessly

My issue is quite a peculiar one. Long story short, I have a desktop computer and a laptop. My desktop can access MyCloud perfectly fine using Ethernet.

But when I try accessing MyCloud using my laptop via wireless, Windows kept showing “error code 0x80070035 network path not found”.

So I tried resetting whatever network settings I have on my laptop from this guide but it didn’t help. http://windows.microsoft.com/en-sg/windows-10/fix-network-connection-issues

The irony is that when I tried connecting my laptop to my network via Ethernet, it instantly can access MyCloud.

Edit: I have also manually keyed in the static ip address “\\192.168.1.12” into the file explorer and it also doesn’t work

Any help on this?

Some additional info:
Desktop - Windows 8, Wired connection
Laptop - Windows 10, Wireless connection

MyCloud settings:
Static IP
Media Streaming ON
Current Version WDMyCloud v04.04.02-105 : Core F/W

Do you have AP Isolation enabled in your router?

And also check to make sure you connect to the same LAN. Compare IPs when connected to wifi vs LAN.
But it does sound as a router/wifi issue.

There are other resources that specifically mention your error code, some with replies from Microsoft support engineers.

https://www.google.co.uk/search?q=0x80070035+network+path+not+found