SOLVED - Help! suddenly cannot access MyCloud anymore

I have been running myCloud Personal Cloud Storage for some time, from my Wind 7 PC as well as my Win10 PC through our home WLAN. Now both PCs are not finding it (error code 0x80070035). I haven’t changed any network or other settings. It eventually connected after reboot of MyCloud, wlan router and PC. A couple of hours later same thing. This happened 3-4 times a day. Today it cannot be connected at all, not even after x times of restarting everything. The light is on blue (static).
I then did a soft reboot (4 seconds with pin).
I tried connecting directly with laptop via ethernet cable. The light just blinked yellow-white. Didn’t even turn blue.
Tried accessing through the remote link ‘MyCloud Dashboard / public’ . It says: 'This site can’t be reached refused to connect.
Checking the connection
Checking the proxy and the firewall

Ran the network diagnosis:
‘DNS Server isn’t responding’
I don’t have a firewall, just running free Avira, but that’s always been running.

What is going on? I am not tech savvy at all, tried to find answers in this forum but the solutions all sound like ??? to me, sorry… I am freaking out, because I can’t access all my files on there. Please help, if possible in layman’s terms. Thanks

This is what solved the problem:

FIRST!! Power OFF the Router, Gateway and or Switch
THEN!! Power ON the Router, Gateway and or Switch
Then Power OFF the My Cloud
Then Power ON the My Cloud

If only I knew it was so easy…