Can't see MyCloud on Wifi but can on Ethernet (Windows 10)

Hello all,

Set up my drive with a wired connection then noticed I couldn’t access it on Wifi when I unplugged the cable.

I have been on the phone to technical support for around 45mins (painful) which ended in a router reboot.and the drive showing which I thought sorted it but sure enough it was no longer showing the next day on wifi only…wired is fine.

Anyone have an idea why this is and what steps I can take to resolve it?


Have you activated so called “AP Isolation” or “Private Protection” mode on your access point? Both would block the netwokr being scanned by wifi clients.

If you access your My Cloud device by its name direct, it should work, like http://wdmycloud or http://wdmycloud.local (please use the real hostname or IP address of your device).

Even file access should work by using \\wdmycloud\Public for example.

Not sure how to do this? I haven’t activated anything and it’s at default settings.

It’s shown previously on the wireless network but only works when resetting the router which isn’t the best solution.

I’ve tried accessing it with the above link already and it doesn’t work.

Resetting the router may activate the privacy protection within the Wifi settings again.
What router are you using?

BT homehub 4

Thaks for reply. Tried to find anything in the Internet about BT Homehub 4 but nothing that helps. Maybe some others here in the forum can join as I am not familiar with this router.

Please excuse this very dump question - just to be sure:
you unplugged the cable from your PC or laptop, not from the My Cloud, right?

Ok thanks. yes hopefully.

I unplugged the network cable from the laptop :smile:

Does your laptop automatically drop back to WiFi if there’s no Ethernet? Or do you have to tell it to do that?

It does it automatically

Is the MTU on everything on your network set to 1500? It may be settable on your computer and the router. It’s fixed to 1500 on the My Cloud.

eth0      Link encap:Ethernet  HWaddr 00:90:a9:f6:46:0c
          inet addr:  Bcast:  Mask:
          inet6 addr: fe80::290:a9ff:fef6:460c/64 Scope:Link
          RX packets:2480554 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1572555 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:571837689 (545.3 MiB)  TX bytes:469083855 (447.3 MiB)

The above is what the LAN port on my My Cloud NAS is set to. Will be the same for you.

I’ve has an issue when I enable an MTU higher then 1500 then wiered comms works and WiFi comms fails.

It’s one cause that would cause the issue you’re experiencing. I can’t see it being WiFi isolation. That simply prevents WiFi devices talking to each other.

Just one extra thing. Sometimes when unplugging the network cable the WiFi could be disconnected and needs reconnecting to the WiFi network?

I don’t gave any experience with the BTHH4.

I have the same issue, but with Windows 8.1. My Cloud is not visible in file explorer when on WiFi but shows up if I connect to the Ethernet. Also, if I type in \wdmycloud connected with WiFi I get a Windows can’t access error. If I type in \IP address, the drive shows up under Network with the IP address. If I then connect the Ethernet \wdmycloud will show up as well.

Any way to have \wdmycloud show up on the network on WiFi without having to type in the IP address?

Right then. Changed the unit to have a static IP and it now shows up on all computers in “my computer”.

This thing is becoming a pain in the arse. I now cannot access it remotely from my phone. The device is showing as having “no internet access”.

As you have set Static IP for the My Cloud, do you have set Gateway and Primary DNS as well in the Static IP?
Without Gateway, the My Cloud doas not know the route to the internet and without Primary DNS, the My Cloud cannot communicate.