Unable to access MyBookLive dashboard

So here’s my problem.

I had assigned a static IP to the MyBookLive a few weeks ago and everything was working fine. Then I updated to the latest firmware last week and everything fell apart.

I can no longer access the dashboard, but I can still access my files through ‘My Computer’ as the drive is still mapped. I find this very strange. Pinging the drive yields no response. So obviously something is still working if I can transfer files to and from the drive.

When I type in the URL of the drive or http://mybooklive, I get the Chrome ‘Oops’ page.

Therefore, I am unable to reset my MyBookLive to a dynamic IP. I’ve tried through my router, as some have suggested, but my router does not allow me to reset or release a static IP, so I’m basically stuck.

My drive was connected to a switch but now I’ve connected it directly to the router, but that hasn’t made a difference.

Has anyone else had this problem or know how to fix it?


i recall previous threads where chrome was a culprit.  do you have a different browser to try?

also, the reset button on the back of the MBl resets the admin password and put you back on DHCP.   you could go that route to get back into the dashboard maybe.

Yes, thanks. I’ve tried that already several times and the static IP doesn’t change. I’ve also tried accessing the db through firefox and IE, and the result has been the same. It’s almost as if it were locked or something. Resetting doesn’t do a darn thing.

I have a similar problem with my MBP.

I tried to login to the dashboard  - first time since I did the firmware update - but Safari won’t open it.

So I tried the installation CD through the setup process - same problem.

Tried Bonjour - again no luck.

Also tried Firefox - same problem.

Every attempt I have results in a 403 Forbidden error.

Any ideas?

Nope. I’m still stuck. I’ll try calling support tomorrow.

I just tried getting into the dashboard for the first time in a while and I have the same problem.  I can access all my files just fine through the mounted drive but the dashboard is inaccessible.  If you find a solution please let us know.

Looks like a hard reboot fixed the problem.  I unplugged the mybooklive for about a minte and after it rebooted I could access the dash again.  Weird that only the dash was inaccessible.

I’m having the same issues, I can’t access the dashboard and thats after doing a hard reboot on both mbl and my router.

Everytime I get to the dashboard website and put in my password and hit enter the website seems to reset itself and I’m back where I started at the login screen.

Please help!

1 Like