Cannot access http://mybooklive

First of all, excuse me for my poor English,

6 months ago I bought a MyBook Live 3T and it worked great!

Yesterday I tried to update MyBook Live with the new firmware. During the process it got stuck. For several hours the message '‘downloading’ was on the screen.

I rebooted my computer and when I entered http://mybooklive still there was the message ‘downloading’. The only thing to do was to reset the MBL. After that I restarted my computer and was able to access via Windows>computer. But what didn’t work was to access  http://mybooklive.

I tried to reinstall the software, but it didn’t help. Only when I disable my firewall (eset) I see the MBL in WD SmartWare but still no access via http://mybooklive.

Can anybody please help me?

I’m using windows 7, IE9 (also with Chrome it didn’t work)

Thanks in advance

try  http://mybooklive/UI

better yet, directly enter the IP that your router is assigning.

neither works…

i just ran the update and when going to the dashboard from quickview, it went right to the IP address, not “mybooklive”.    Maybe the new firmware gets the IP from your router and then has the dashboard and software reference that, instead of just going to “mybooklive” and hoping your DNS know how to translate that.

Try using the actual IP assigned by your router.

I know what the ip adres is form the MBL. I also tried to connect to it by http:// but it didn’t work.

WD smartware shows the MLB as well as WD Link. Because I can’t connect to the dashboard I cannot update the MBL with the new firmware. Maybe there is another way to update the firmware?

When I go the my routers’ dashboard the MBL is visible with the ip adres and mac adres. Maybe there is a problem?

Please help!


I have been having the same problem too. I cannot update firmware as long as I cannot access the dashboard interface…

Maybe next time you should direct connec tto your computer for updates; it will be faster that way…

As for my case, the dashboard takes a very long time to load up, and even it brought me inside, I cannot access the interface menus…it is too slow…

I tried a direct connection using ethernet from the MLB to my laptop. Even that wouldn’t work. I also did reset the MBL and the router. From now on I think the problem is the MBL itself because of the failure during updating the firmware.

How can I update a new firmware version without using the dashboard?

I also just did the firmware update and now the gui doesn’t load. Shares still accessible, and remote wd2go still works. Just unable to actually go to 


but what does work is Http://mynas:9000 to load twonky. Its just the UI of the my book that seems to effed. 


it works again!!! by using putty and the firmware file from!


what commands you use?

I’m not sure… but I think it was:

/usr/local/sbin/ /DataVolume/cache/apnc-021009-124-20111113.deb

In my case my upgrade was not working good. I rebooted during the update (with was stuck). Happely it was possible to upgrade again via the command line, because http://<ip) was not working anymore…

Good luck

i think someone earlier said smartware saw the drive.  If you have the quickview icon in your notification area there is an option to update from there, without going into the dashboard.  I did that for this release and it worked just fine.

Hi, can you please share the command

Can u send me the link please wich firmware version u have installed . Coz i have same problem Thanks