Cannot access the dashboard on Mybook Live 1TB Nas drive

Dear all. This is my first post but looking at this excellent forum I am hoping someone can help. I have a 1tb Mybook live Nas drive but I am unable to connect to the dashboard either by IP address or by connecting to http://mybooklive.local. When I first installed it I was using Snow leopard from my mac which I have since upgraded to Lion. Everything was initially fine but after a couple of weeks I could no longer access the dashboard. I have tried Safari, Firefox and also IE to no avail. I have also tried to connect from a Windows Vista laptop which also did not work. I can however access the drive via finder on the mac and explorer in windows and save and delete files. The other thing I have noticed is that when I click on the WD smartware icon on my mac the MYbooklive option is greyed out. I have tried re running the setup software from the MBL drive and it says that the device is found but it is not showing the mac address of the device and when I try and access the settings all of the browsers are refusing the connection. I would like to update the firmware to make the MBL compatible with time machine on my mac but I cannot get into the dashboard to do this. I have tried resetting both my router and the Mybook Live and also reset the MBL using the reset button on the back. Please forgive me if I have missed anything but if anyone has any advice I would be extremely greatful. Many thanks. Barry.

This is not normal, have you try to use Chrome? I have issues accessing the dashboard using Firefox but never with Chrome.

 I haven’t tried Chrome but will give it a go tonight and post an update. However, before the dashboard stopped working I was able to use the other browsers without any issues. Many thanks for your reply. It is very much appreciated. Barry.

i recall reading about firefox having a proxy setting in the browser setup that would affect this.  can’t help you directly but that might be worth a search, or maybe someone will also recall that issue.

I have the same problem and dont know what to do.

Has anybody a solution? i can not copy files. I need to activate ssh. But how, when I cant use the interface? Help!

I have the same problem.

I can connect fine with MBL connected direct to the IMac with a network cable.

Over wifi the MBL Dashboard does not load completely.


Morning all. I tried Chrome over the weekend but this did not work either. Thanks for the suggestion though. Regards, Barry.

wd said on another thread there might be dns cache issues.  try changing your DNS server?

Tried changing my dns server and I am still getting the same. Is there any way of setting the drive back to factory defaults at all?

How about, let the drive go into standby.  I think the default is 10 minutes.  If not then you don’t have much choice but wait for the green LED to stay on (no flashing) for about 5 seconds and then pull the power plug from the back of the drive and then power it up.

I have had one issue with the Dashboard in the past where it failed to respond after a reboot.  Ok, I have SSH on so I initiated a full shut down that way to be able to power-cycle the MBL.  When I did that the Dashboard became available.

Hi Myron. I gave that a try last night but I am still unable to access the settings area of the dashboad. Unfortunately I do not have ssh enabled either so I cannot upgrade the firmware via that route. I really appreciate all of the advice to date. Many thanks. Barry.

I am having the same exact problem. I just upgraded the firmware through the Dashboard yesterday. Today, I could not access the Dashboard. I tried accessing it via**  http://mybooklive.local, and . Neither option worked. I can access it through ssh and shared folders but no Web UI. I tried both windows and linux. I also tried resetting the device via the hard reset button and that did nothing either. **

I have the exact same issue, just on a 2TB edition. Anybody tried to revert to a previous version of the firmware, if possible?


I have to add a “ME TOO!” to the thread. I stumbled on it trying to research how to fix the issue. It seems to have happened suddenly. Web browser access had been working both remotely and locally. I have FPMGR installed, but doubt that is the issue. I can access the drive via ssh logging on as root…no trouble. I can mount the drive on the local network. WD Smartware runs okay. I do notice that WD Quick View no longer shows the used % or temperature correctly…it used to. I do assume this could be related to the no browser access issue.

This issue appears on all the computers in my network and is not VPN nor VLAN isolated. The drive is on the same subnet.

What I have done…

upnp running and supported = yes. The drive is recognized as a Twonky server and streams fine.

80 and 443 ported to the local IP = yes (removing this makes no difference)

stopped the anitvirus = no change

Wahoo! A firmware update brought my connectivity back. I needed to log in through ssh using putty. I put the deb file in public and ran the updater against it…back in business.

I am having the same issue with my MBL 2TB.  As with others I can see, read and write to the drive through finder.  I can also stream media from it to QuickTime, etc.  But I can not access it through the Dashboard UI via http://IPAddress or by running from the install disk or from the MBL’s software folder. 

WD Support has suggested I carry out a Factory Restore to address my issues.  Is there any way to carry this out other than going through the Dashboard UI?  I unfortunately did not turn ssh permissions on before I lost the UI.

I tried a reset with power on but that accomplished nothing i.e. my password did not reset.  I also tried a hard reset by pushing the reset while powering up.  Also no effect.

I am beginning to think I should just get WD to replace it with a new unit.

There is no hard reset using the reset button. This is what the reset button does . . .

NAS:/usr/local/sbin# cat
# © 2010 Western Digital Technologies, Inc. All rights reserved.
# This is called by resetbtnd whenever the reset button has met the criteria for a reset. This script implements the actions for the reset button.

logger "reset button pressed, invoking reset actions"

# remove owner password
owner=`` ${owner}

# set root password back to default
echo "root:welc0me" | chpasswd

# set network to dhcp

1 Like

This is good to know - and useful.  Thanks.

Not much of a “reset”. Would be useful if this script made the assumption that there is something up with the Firmware and restored some other internal configuration files to known working conditions and also restore files like restore everything under /var/www with the assumption that all or some of the source files have got screwed up, so restore them anyway.

Common sense really.   (Humanity does have a issue with implementing common sense.)

That’s what I would have done. For the reset button action to assume the Dashboard UI and Apache2 configuration has been seriously corrupted so pressing the reset button will fully factory restore those two software components as well as resetting the passwords, setting the networking back to DHCP and then rebooting the MBL.

Bet that would have fixed many of these Dashboard UI is dead problems.  :smiley:

Clearly a result of a recent firmware upgrade to the Mybook Live and it hit all drive sizes of course.  I bet a lot more folks are affected than these series of messages indicate.  I’ve got the exact same problem.  My UI access was fine a couple of weeks ago and now I can’t access the Dashboard using the password.  The LOGIN UI accepts the password but it doesn’t advance to the Dashboard, it just redisplays the same screen after hitting enter.  I also do not get an ‘Invalid Password’ message.  If you try any type of resets, it doesn’t change the behavior.  Interestingly, if you go to the WD QuickView utility and choose the ‘Shutdown’ option, the password works and the device shuts down normally.  It is clearly a software corruption related to the UI.  Now what though?  I can RMA the device and get a refurb replacement for my nearly new MBL - that is about the only option apparently.  Thankfully there is no data loss.  Unfortunately I also did not set SSH which would have been smart (DUH!) and is the only means I’ve seen for a resolution.  This issue shows up on other Board threads as well such as: