My Book Live not connecting


I have been trying for over a day to connect to my book live. 

It was working fine but now I cannot connect via the ip through chrome (myip.10)

i get the error message

“Google Chrome could not connect to myIp.10”

and when I try to use the mapped drive on network connections that was working fine a couple of days ago.

I get the error message

“The network path was not found”

I have tried unplugging everything (pc, router and drive) and holding the reset and no change.

The lighs on the back are Solid Green (bottom) and flashing green (top)

I am not sure what to do now can anybody advise?



What is “myip.10?”   Is that the name you gave the MBL?

No Sorry this is my Ip address with 10 at the end (the ip of the hard drive)

What color is the light on the front of the unit?

Have you changed the name of the MBL, or set a fixed IP address? If you did the “reset” on the back, then it will set the MBL back to DHCP and not a static address.

Try going to a command prompt and running “ping mybooklive”(Windows) or a Terminal and “ping mybooklive.local” (Mac).


Thanks for the response.

There is no light on the front.

The Ping request could not find the host mybooklive. Also I cannot see it when I search my network. I am using Windows 7 by the way,



Ok I have taken the casing off and the light on the front is deffinatly not on at all.

I can feel the hard drive moving. The lights on the back where I plug the ethernet are on and the light where i plug it into my router is flashing to signal transfers.

I am realy stuck on why this is not working now. 

Ay suggestions on how I can find out will be much appreciated.



Guys - I have a similar issue -  Not able to make contact with drive from either Mac / PC or mobile devices - 

All my data is here and the back ups from my MAC’s :manmad:  

have tried re set - switch off on -

Has a blue light on front with occassional yellow flash -  rear has green flashing light -  -  router appears to be fine - and swapped lan cables  - no diff -  

Any suggestions 


Im having similiar problems, the LAN lights are flashing but none of my home computers can find my NAS.

SmartWare cant see it either. Ive tried switching LAN ports on my router, restarting my router, restarting the NAS, searching for it again on my computer, nothing seems to help. I would’ve needed the files on it today, so this is really disappointing, one year old product failing like this…

Similar for me too.

A few weeks ago I found I couldn’t connect to my MBL via shortcuts on my Windows (7 Ultimate x64) desktop or laptop, nor could I connect by using a UNC path or the IP address.  I tried remapping drives to no avail.  The drive could be pinged by its IP address and by its name, but I couldn’t connect to it.

At the same time I also found the web interface was behaving strangely, and despite being logged on as the drive owner and the PC administrator every time I tried to do anything to the drive such as create a folder or a user, it came back with a “You are not authorized to perform this task” error.  I tried reinstalling the latest firmware (which was already installed) but again it returned the same error.

Bizarrely I could still connect to the drive by using SSH via Putty (and also by an application called WinSCP) but not by conventional means.

I tried doing a reset by pushing the button on the back of the drive with a straightened paper clip for a minute or so but there was no change.  I also did a quick factory reset, then a full factory reset, knowing this would lose all my data, but again nothing changed - the drive was still inaccessible.

I phoned WD and reported the problem and was advised to wait a week and submit an RMA - the week was down to them migrating their support systems I was told - but when I tried this it told me my drive was out of warranty (it was bought in January 2011) and unregistered (I registered it as soon as I received it.)  I have re-registered it but am still unable to place an RMA.

So now I’m stuck with a drive I can’t use, after just over a year of ownership.  So much for the three year warranty it was supposed to have.  Needless to say I’m not happy.

OK the front light is red.  

I have tried plugging the drive into the laptop directly and still does not work. 

So am assuming that the hard drive is now broken. 


I am also having same issue since last couple of days. It was working properly, however since last couple of days, I am not able to connect MLB. I tried restarting and connecting through router as well as connecting directly to my laptop with no luck :cry:

Anyone having any idea how to resolve this. I have my all the backups in my MBL and do not wish to loose this.

Is there anyone here from WD technical team, who can comment and suggest possible solution?


i have the same problem.

also - i cannot update the firmware - it just hangs and the manual update from the wd site is '‘currently unavailable’"

i am also having endless issues with my 2 x WD streaming media devices and it took 5 days for WD support to come back with a flipant and  generic response.

beginning to think the products are utter  rubbish and the support teams know it…