Ultra wont eject

My 2Tb ultra passport wont let me safely eject from my pc which is running windows 10, i keep getting a message that windows is unable to stop this device, so can any one offer any help solving this problem please

Any time a drive cannot be ejected, just shut down the PC properly and Windows will eject the drive during shut down. Once completely shut down, disconnect the USB cable from PC. You can now reboot the PC. Once it is completely rebooted, plug the drive’s USB cable back into the PC. It should properly connect, so test that it did. After a minute or two, safely remove the drive and it likely will do so. If it doesn’t, well, you know how to “force it” to.

If this problem continues, you likely have other issues. Try completely uninstalling the drive from the PC. Disconnect it and reboot PC. Once PC is totally rebooted, re-install the drive by plugging it into USB port of PC. Perhaps it will safely remove now. Otherwise, I have run out of suggestions.

Thanks for your reply, How would i completely uninstall the drive from the PC? also is doing this safe, i wont loose any photos or documents on the drive?

I face this issue all the time.

It’s usually a process running on the computer (often, an Antivirus program) that’s scanning or holding a file open, and won’t release it when instructed.

Mike’s advice is exactly what I have to do when that happens…

I’ll take time to cover un, and re-installing a drive, device, etc. if the more basic first steps don’t solve your problem.

mike27oct can you explain how to reinstall a drive, also is doing this going to case the hard drive to loose any photos etc?

No data will be destroyed or deleted unless you format the drive accidentally or on purpose. Just NEVER format a drive unless you intend to wipe it clean.

OK, the info you need will be found in this google search from sources like Toshiba, Microsoft and the others listed here.


mike27oct tried your suggestion and it worked once, it seems to be this only happens when you open up any photo in Photoshop or Lightroom

If there is a relationship between Photoshop and your drive getting bunged up, seems like you need to check with Photoshop forum or their support. Good luck getting this resolved.

Do you know anything about unlocker programs?

Probably not since I don’t lock things – so I can’t get locked out! I only have ONE password protected file, and it is a MS Word file with all my online passwords, and other personal info in it! I only need to remember one password; how to open that file!

Never though of this before but i opened the WD smartware utility right clicked on the hard drive and it give me the option to safely remove, it switched off the very small light on the drive but no pop up message so i take it it is okay to remove the drive from the computer?

If you have taken it off already, click on the safely remove device tab on tray and see if it still shows. If not, then it is “removed” so take it off.

I have to say that this is an ongoing issue and is quite annoying. I have had about seven drives over the past seven years. They work fine at first, but after about a month they begin to say that the won’t eject. I have to turn off my computer. This is not a good workaround.

Every single drive has failed and wouldn’t work again until I reformatted. I can do this and usually get a year out of it.

I don’t understand why the ejection issue still exists. It needs to be really repaired.

I had the same problem. My fix was to,
“right click” on the icon to safely remove [Eject device].
Then click, [Open Devices and Printers] “right click” on the device you want to remove.
Click on [Troubleshoot]… Troubleshoot found a problem & fixed it. So I could remove device safely.

Unbelieveable, how long have you guys been making hard drives? I just got a new 1tb ssd from my company and it’s having the same problems all of my other WD portable drives have ALWAYS HAD.

This is obviously a problem they know about and refuse to fix.

Last western digital product I ever use, luckily I didn’t pay for it

haha, 4 years later and I had to refer to this post to get mine to eject. I honestly think that this is not necessarily a “problem” but rather, they need to have a section in the manual about how to properly eject the drive.
I had the issue, but my computer did not even have an option to “safely eject” when I had the drive and file explorer open. Once I read to go into the SmartWare software and right click the drive, it’s pretty easy to see that they just want you to have to download their software. Clicked safely eject, my computer did the classic eject noise, but no notification as it was not ejecting via my computer’s file view, but everything ejected smoothly and with no issues.
Still a pain in the bunger to spend a half an hour surfing the interweb to figure that out. AT THE VERY LEAST they need to make that easier to find.
Thanks to all of the previous comments and posts in getting me to the answer… was about to “force” it out and didn’t want to lose 250g of docs/pics/videos…