How can i "Safely Remove" My Passport Ultra from my PC?

I can’t EVER “Safely Remove” my My Passport Ultra drive from my PC!
The computer’s an HP notebook (if that matters), and it’s running Vista (64bit).
I can’t believe that there’s NO way to eject / unmount / “Safely Remove” the drive from my computer when i need to disconnect it from the port!
But i can’t find any way to do it, other than shutting down the system entirely. Obviously, shutting down every time i want to unplug the drive is so RIDICULOUSLY impractical, i can’t even consider it as an option.
The “Knowledge Base” pages don’t seem particularly knowledgeable on the subject.
The only suggestions offereed there are to close any applications that are acccessing thedrive, including the Windows indexer and any virus/spyware programs that might be running.
Obviously I’ve already done that. I’ve set the drive to never be idexed or scanned/monitored for viruses and spyware.
And yet still, every time i try to eject the drive, it’s the same message:
“Problem Ejecting USB Mass Storage Device”
“Windows can’t stop your ‘Generic volume’ device because it is in use. Close any programs or windows that might be using the device, and then try again later.”
Sometimes, even after i manually end the WD software via the Windows services menu, they just start back up again a few seconds later (even though i set them in the services menu to only be launched manually).
But the rest of the time, even when none of the WD software is running, Windows still tells me the drive is in use and won’t let me eject it.
There’s GOTTA be a way around this.
I’ve never had this problem with any OTHER external drive.
I’m still waiting for a reply to the Support Case i submited yesterday, but i’m getting impatient.
Does anybody else know any solutions to this problem? I can’t be the only one stumped by it…

1 Like

Hello and welcome to the WD community.

Are you using any type of computer monitoring program or anti virus program that could be trying to access the unit all the time?

Norton is running, but as i mentioned, I excluded the drive from all virus scanning and protection in Norton’s settings.

Update:
I think I finally solved the problem (no thanks to WD…).
I had already excluded the My Passport Drive from being indexed by the Windows Indexer.
And from being scanned or protected by antivirus software.
And from being monitored by Windows Defender.
What i didn’t realize is that the WD Smartware software and the other WD applications were running automatically at startup, whether or not the drive was connected.
And so even if i closed them manually, they relaunched automatically in the background again.
Finally, i used a third-party program to remove all the WD applications and services from the startup and autorun lists on my computer.
This seems to be working so far.
I’ve been able to connect the drive, manually run the WD Smartware application, perform a backup, and close WD Smartware again. And then Windows allows me to “Safely Remove” (eject) the drive without any problems.

I’ve gotta say that it makes no sense for WD’s software to be ser up to run automatically, but that’s the way it was set up by default when i installed it. Maybe it would make sense if WD expected its users to leave it connected and running all the time, but this is a PORTABLE drive. Leave it connected and constantly running in the background would defeat the purpose of being “portable” entirely, wouldn’t it?

The “solution” I THOUGHT i’d found (removing WD applications from startup and autorun lists) seemed to work – intermittantly – for a while. But not often enough.
Occasionally I’m able to end the WD applications in order to “safely remove” the drive.
But far more often, they will not close (or if they close, the reopen immediately reopen silently and remain running in the background). So the drive cannot be removed.
So I’ve had to avoid EVER connecting the My Passport drive to my computer at all.
Which makes it impossible to run backups.
Which really defeats the purpose of ever buying the drive, as it’s completely useless to me if I can’t ever connect it without facing the impossible task of disconnecting it.

Stil finding it pretty hard to believe the manufacturer has no useful solutions to what i assume is not an uncommon complaint.

1 Like

I have to say I have the same issue as well. This is with the new 4TB My Passport (2016/17 version). I have:

  1. turned off my sophos antivirus,
  2. manually closed the WD application tasks from task manager (WD utilities and WD security was running in the background) with no indication in the toolbars of it running,
  3. and unindexed the whole tb drive itself.

These were all done to no success. Anybody out there to help?

Irritating isn’t it.
Here’s where the cure is.
control panel
device manager
disk drives
{for me} wd my passport clk it and go to policies.
There you get to see the pain. Quick removal(default)
I have confidence thats the culprit so I have to reboot for it to take effect and test it. But it pretty much explains it.

I don’t know if this helps…but the above suggestion to make sure in Device Manager that The Quick Removal choice option was one fix (Quick Removal is the default setting). Did not work for me.

My New 2018 Passport still was not able to be removed using Safely Remove function. So instead in Device Manager, click on the disk drives, then click on your WD external drive, and select Policies Tab and for me, I chose the option, Better Performance and it fixed my problem and works every time for me. You can use the Safely removal tool and it allows you to eject easily and safely. I’m using the latest Windows 10 OS.

I hope this may work for you as well!!

I finally realised that for me the app using the passport was the WD Discovery app. To eject the passport, open WD Discovery. In the window that opens, your passport device should be visible and there is a settings icon next to it. In the settings, there is an option to eject the passport.

1 Like

I used Task Manager to end all the ‘WD’ processes I could identify, still could not get permission to Safely Remove My Passport Ultra. I also tried using ‘Quit’ in the WD software, it wouldn’t allow removal either! Clayzz post above led me to a search that found Microsoft’s “Windows 10 default media removal policy - Windows Client Management”. The jist of it is that “Windows defines two main policies, Quick removal and Better performance, that control how the system interacts with external storage devices … Quick removal: This policy manages storage operations in a manner that keeps the device ready to remove at any time. You can remove the device without using the Safely Remove Hardware process.” Hope this helps. Link to the Microsoft document, https://docs.microsoft.com/en-us/windows/client-management/change-default-removal-policy-external-storage-media