Twonky renaming files to Stereo

Hi all,

I’m becoming extremely frustrated with your Twonky server when ever I convert a file from format A to format B without fail everytime it comes up with Stereo on the Twonky Server… yet on my file explorer for windows 10 it comes up with the correct file name. The confusing part is the file plays perfectly fine I just cant organise my media with every file name as "stereo. Below I have attached a screenshot of my issue it only is coming up with stereo on the screenshot in file explorer as I went into the network twonky side.

can anyone please help me out im about ready to give up and use something else.

It appears (per the image) you are using a My Book Live. That is a completely different device than the My Cloud which is the subject of this subforum you posted in. There is a dedicated subforum for the My Book Live.

https://community.wd.com/c/wd-legacy-products/my-book-live/50

To the issue of Townky “renaming” your files. First it is not renaming your files. Rather it is parsing the file’s metadata and using that metadata to display various things about the media like the; title, track, album, artist, etc.

Second, you are likely viewing the files via the DLNA server entry for the My Book Live in Windows File Explorer, and not the file server entry in Windows File Explorer. As such you will see the metadata displayed rather than the actual file name.

You can use any number of software programs to edit the meta data of a media file. MP3Tag (https://www.mp3tag.de/en/) and MediaMonkey (https://www.mediamonkey.com/) are two popular free programs to edit media file metadata.

For My Cloud users, again the My Cloud and My Book LIve are different devices despite both apparently using Twonky, there is a unofficial Twonky FAQ of sorts that has a bunch of suggestions and tweaks when it comes to Twonky, the My Cloud and media files. Warning: various tweaks and changes in the following link are for the My Cloud, they may not work on other non My Cloud devices that use Twonky.

Are you using Handbrake for the conversions by any chance? I dont know why it does it, but i did find a workaround. Edit the file metadata (right click on the file and select Properties, then Details) so that the Title field is the name of the movie/video.

Does anyone else have a better solution?

Yeah it’s a problem with Handbrake. For what ever reason there doesn’t seem to be the ability to prevent it from doing that.

Personally I use MP3Tag as much as possible when dealing with metadata tags on MP4 and other supported media files. Its easy to select a number of files, then right click and select Remove Tag to remove all the tags from a group (or individual) files. One an also select a group of files and assign the same metadata field to all of them. Or one can setup the Convert (Tag to Tag) option to convert the file name to the metadata Title field. MP3Tag isn’t perfect but one can do quite a bit with it once one gets the hang of using it and its many options.

MP3Tag examples:
Remove tag
mp3tagremovetags

Convert (file name to Title)
MP3TagConverFilenametoTitle
In the above example the program takes the (movie) file name “An American Pickle.mp4” and creates the Title field (that Twonky and other media servers will read) “An American Pickle”. The conversion option drops the file extension.

Thanks Bennor. I will have to give that a try.

Hey guys,

Thanks for all your replies yes im using handbrake to convert the files. I did find a workaround within handbrake, I figured if its just reading the metadata from the file in this case being the audio metadata i will just change the name of the audio track from “stereo” to the name of the movie/tv show and that worked, also I add .mp4 at the end of my file and remove the m4v extension its a a pain to have to do but it works for a short term fix.

Ive at tached a screenshot to explain what ive done.

Paul when you say this "

Edit the file metadata (right click on the file and select Properties, then Details) so that the Title field is the name of the movie/video.

After doing this how do you add a title on the properties box of the file?

My Workaround:
Open Twonky Server Admin using e.g. http://192.168.xxx.xxx:9000 and Click “Settings” > Navigation.
Here for navigation mode “by directory” you can check the checkbox that files should be displayed using filename. Now Metadata no longer plays a role and the files a shown correctly.