Please help me fix my videos

Many of my mp4 videos captured on my phone are showing up in the Twonky DNLA as audio and not video files, please can someone tell me which part of the meta data is causing this?

---- ExifTool ----
ExifTool Version Number : 10.50
---- File ----
File Name : 20170426_081129.mp4
Directory : .
File Size : 41 MB
File Modification Date/Time : 2017:04:26 08:13:22+01:00
File Access Date/Time : 2017:04:28 13:17:09+01:00
File Creation Date/Time : 2017:04:28 13:17:09+01:00
File Permissions : rw-rw-rw-
File Type : MP4
File Type Extension : mp4
MIME Type : video/mp4
---- QuickTime ----
Major Brand : MP4 v2 [ISO 14496-14]
Minor Version : 0.0.0
Compatible Brands : isom*mp42
Movie Data Size : 43235334
Movie Data Offset : 32
Movie Header Version : 0
Create Date : 2017:04:26 07:11:42
Modify Date : 2017:04:26 07:11:42
Time Scale : 1000
Duration : 12.24 s
Preferred Rate : 1
Preferred Volume : 100.00%
Matrix Structure : 1 0 0 0 1 0 0 0 1
Preview Time : 0 s
Preview Duration : 0 s
Poster Time : 0 s
Selection Time : 0 s
Selection Duration : 0 s
Current Time : 0 s
Next Track ID : 3
Play Mode : SEQ_PLAY
Handler Type : Metadata Tags
Com Android Version : 6.0.1
Track Header Version : 0
Track Create Date : 2017:04:26 07:11:42
Track Modify Date : 2017:04:26 07:11:42
Track ID : 1
Track Duration : 12.23 s
Track Layer : 0
Track Volume : 0.00%
Matrix Structure : 0 1 0 -1 0 0 0 0 1
Image Width : 1920
Image Height : 1080
Media Header Version : 0
Media Create Date : 2017:04:26 07:11:42
Media Modify Date : 2017:04:26 07:11:42
Media Time Scale : 90000
Media Duration : 12.23 s
Handler Type : Video Track
Handler Description : VideoHandle
Graphics Mode : srcCopy
Op Color : 0 0 0
Compressor ID : avc1
Source Image Width : 1920
Source Image Height : 1080
X Resolution : 72
Y Resolution : 72
Bit Depth : 24
Video Frame Rate : 60.011
Track Header Version : 0
Track Create Date : 2017:04:26 07:11:42
Track Modify Date : 2017:04:26 07:11:42
Track ID : 2
Track Duration : 12.24 s
Track Layer : 0
Track Volume : 100.00%
Matrix Structure : 1 0 0 0 1 0 0 0 1
Media Header Version : 0
Media Create Date : 2017:04:26 07:11:42
Media Modify Date : 2017:04:26 07:11:42
Media Time Scale : 48000
Media Duration : 12.25 s
Handler Type : Audio Track
Handler Description : SoundHandle
Balance : 0
Audio Format : mp4a
Audio Channels : 2
Audio Bits Per Sample : 16
Audio Sample Rate : 48000
---- Composite ----
Avg Bitrate : 28.2 Mbps
Image Size : 1920x1080
Megapixels : 2.1
Rotation : 90

Hi serestor.

Changing the file name appears to solve the problem and the mp4 files are then correctly recognised by twonky as a video file. This is the odd thing, it isnt a problem with the encoding as per say, but how the .mp4 file is detected as video vs audio by twonky. Changing just the file name is enough to get the files correctly scanned and identified. If that doesn’t help let’s wait and see if other users can share their experience here.

Doesn’t work for me

renaming the original file then recopying to mycloud still they detect as audio
renaming the files once on mycloud still detects as audio

I have far too many videos to re encode them all and I don’t want to then have to redo every time stamp etc as well. Surely there must be a easier fix I assumed the metatags or something were to blame for this

I have the same problem, see this thread:

Renaming of the files didn´t help.
What about to update the Twonky server, the one with the bought MyCloud device is pretty old…? WD does not offer free newer updates of Twonky server.

renaming to m4v doesnt fix it, the files are encoded by my phone i do not know what codec is used. I just found that renaming to mkv does make them show as videos but no file preview is available so it is not a solution

AVC it says in mediainfo

galaxy s6, using the camera

Do you need actually to use the Twonky DLNA server?

What client are you using to view your videos? If it’s Kodi or VLC, you can connect to the file server, and those apps will index your fles for you. And provide a better interface.

Oh, and what means are you using to determine Twonky thinks the files are audio? A DLNA client, or the media browser built in to the Twonky UI at port 9000? Or the MyCloud’s Dashboard display?

Note that I’m not trying to defend Twonky, or the way WD have very poorly ‘integrated’ it into the MyCloud. I’m just trying to ensure we’re trying to fix the right problem…

Yeah; I just downloaded the test file, stuck it in a directory, got Twonky to rescan the library, and it hasn’t identified it as a video (I only scan that location for video, not nusic or photos).

See my response to a similar question asked in another discussion today for some additional suggestions beyond those already suggested.

What is this supposed to be a video of? Both Kodi and WMP show it as a blank black screen.

Yes, I know. I’ve read the thread.

I’m just trying to confirm that it is expected to be a blank, black, 5-second video clip, and that this isn’t the result of some encoding problem. That’s also a vital step in this sort of diagnosis; “what do I expect to see?”

it is just a black video yes, twonky still sees that and all my other phone videos as audio though

Whilst I appreciate that it’s not a fix for the Twonky problem, I’ll ask again; do you need to use Twonky DLNA media server to access your videos? What device and client are you using to view the videos that needs DLNA? A ‘smart’ TV?

Have you tried reencoding the video using Handbrake or similar video encoding programs? As previously indicated in the past when I’ve had video that Twonky wrongly classified as audio, reencoding the video usually fixed the issue.

My guess is that there is something with the way the Galaxy S6 records video (in other words the codec the phone uses to record) that causes the problem. Could be the video file size the phone is recording your video at (1980x1080 if I remember right). Try selecting a smaller resolution size for recording within the phone and test again. I noticed when I run the 5 second blank video file through Handbrake it reduces the file size tremendously and Twonky no longer categorizes the video as Audio. It also doesn’t display it under video properly either.

Yes I am using a smart TV and also localcast app on my phone to cast to a chromecast device in the bedroom too

I know I can reencode the files but I have literally thousands of files and every time I use handbrake it screws up the date formatting which is a real pain, surely there must be a better fix?

Not all of my phone videos don’t work on twonky, some show as audio some show as video all using the same settings it is so weird I hoped I could just fix some metadata to fix this issue but it seems it may be more deep rooted than that?

I have the same exact problem. All video captured by my samsung s6 ( and new s7 edge ) are categorized as audio by twonky. Note, prior to June 2016, video captured on my S6 was categorized CORRECTLY However, in June 2016 android was updated on my phone and ever since , video is categorized as audio. I’ve been troubleshooting ever since and still haven’t found a solution. As a result, I started using Plex. Plex works correctly.

It frustrating because since Twonky categorizes the video as audio, I can’t play the video on my samsung smart TV. I have noticed to if you edit the video on your phone ( without changing the video ) and save the video, twonky will recognize the video as video. For some odd reason, twonky doesn’t like the original video but does like the 2nd copy. Still, I have lots of existing MP4 videos on my WD cloud that twonky miscategorizes. I don’t want to resave tons of videos just to get twonky to recognize them

The problem definitely started after my phone’s upgrade to android 6 marshmallow in 06/2016. All worked perfectly prior. I I really hope someone can find a solution.