Two WD essential PCB boards destroyed, need help

Hi

I want to find out how to save my data without sending my disk to some expensive recovery service.
I have two WD Essential disks, one at 3TB and one at 4TB. Both PCB boards are destroyed by power surge through the USB port.

These disks have been removed from the casing to test if they work without the PCB board, and they do, but i’m told i need to format the disks to use them. So apparently the stuff on the disks are encrypted.

3TB PCB : 4061-705094-301 Rev. AA
4TB PCB : 4061-705149-000 Rev. AA

What can i do to fix this?
Does anyone know?

Hello,

Replacing the circuit board on a hard drive is not a recommended method for recovering data or drive functions as this will void the warranty on the hard drive. =

Check this link for more information.

How to recover data on a drive, obtain a circuit board, repair a drive, or find a list of WD data recovery partners 

Thanks for your answer.

I am not worried about the warranty. All i want to do is to recover my files without it costing me a fortune.
And as far as i know what i need to do, is to replace the PCB board, and swap the flash memory chip from the old board to the new. Then i can access the files, as the encryption codes on the disk and the chip then match.

If this is so. Then this is what i will do. I have friends that work with small electronics like this and they are really good. So swapping the chips is a walk in the park.

but i need to be sure this is the method.

1 Like

Try checking the posts by fzabkar. He has guided people thru bypassing a burnt diode to gain access to data. This usually was the result of using the wrong voltage adapter. You can also try a PM to him.

Joe

I have talked to him now. But now remains one more obsticle.

The PCB board i have has the “number”. 4061-705094-301 Rev.AA

I can not find this exact number when i google.

But i can find plenty of 4061-705094-001 Rev.AA
Now the question is. What does those numbers mean?

What i am going to do is to swap the flash chip from the broken one to the new one.
So does anyone know, with this information at hand, if i need to buy the exact same?

I’m not an expert but after weeks of trying to figure out my own HDD issue, from what I read so far, yes, you will need an EXACT same board to do the transfer.

Best of Luck to you!

Thank you.

I am doing some research on this. And trying to find out. If i do find out, i will post the solution.

The last thing i learned is that the REV, is what tells what kind of encryption you run. It means that the REV can be different if your plan is to swap the flash chip , as then you will move your old rev over to the new board.

I have also found out that some companies sell chips with all Revs supported.

All i now need to be sure of, is if i need to have the last three numbers exact.

And it is solved.

I bought two new PCB boards from ebay.
The one i bought for the 3TB disk did not have the exact same number.

mine is : 4061-705094-301 Rev.AA
his was : 4061-705094-001 Rev.AA

As it turns out, he was right. Only the first two rows of digits and the REV needs to match. The last three numbers are only serial. I have just extracted all the data from my two drives, without any problems what so ever.

The 3TB PCB board i bought from a company called iKit Technology in Hong Kong. They sell PCB boards that has support for All Revs in their flash chip. So only thing that has to match is the numbers, not the REV.

Well anyways, this solved my problem, and it cost me only 40 USD to fix both drives.

3 Likes

Thanks for posting back about the numbers.

Joe

Hi SunWorshiper.  I (think I) have a similar issue with my 2 TB Mybook Essential PCB.  Photo below - damaged component is U5, which is apparently the DC>DC stepdown, some sort of overload protector - it’s the melted black diode directly above the nice oxidation smudge on the far right of the PCB.  I sent you a PM with some additional details and a question or two.

 If it turns out my situation is in fact like yours, I’ll be happy to follow up with posts on this thread describing my own results.  Thanks a lot!

Here is some other info to checkout  http://www.hddoracle.com/viewtopic.php?f=59&t=1119&p=5033 that might help. Also try looking on that forum for posts by fzabkar.

Joe

Hello Sunworshiper,

I’ve had this same issue and seek to do the same only i’ve done just as you have and to no avail. I purchased a chip and my MyBook is still reading as unallocated, i’ve not formatted it as it would lose all my data. so is there anything else i should check or try?

Thanks

Hi SunWorshiper - my external drive MY BOOK ESSENTIAL 3TB seems dead (does not light up when connect AC adapter and connect to computer anymore). Dismantled and connected the drive directly internally and it was recognized but says have to initialize the drive (which I didn´t do to not loose my data!). I’m guessing its the Controller board as well. Question: did you have to do any chip swapping or just replace the Controller board itself to read the data again? My board 4061-705094-001 Rev AD

I think i got the same problem

So the solution is order a new board

I use some software and i access few 2TB but what left i can access

Check - 4TB - My Book - Board Damage - How Recovery Data

xx

I need the 4061-705094-001 Rev AG…anyone can sell me this controller? :sleepy:

Listen Uncle!! the drives are probably out of warranty and people are desperate to get their data. Since WD doesn’t really help lets do it ourselves!!