Troubles with my Western Digital Elements

The usbport from my Western Digital Elements external drive broke. As the warranty had already passed I decided to take out the drive and make it an internal drive. However my drive doesn’t show up where it usually showed up.

It looks similar to the problem described in this thread:

http://community.wdc.com/t5/External-Drives-for-PC/FAQ-External-hard-drive-no-longer-shows-up-in-My-Computer-and/td-p/133426

However I have applied the suggested solutions with no effect. I use a SATA cable and power cable from my Power Supply Unit that I have tested to work. I ran several scans to see if the drive is ok. It does show up in the connected hardware screen.

I have also tried to use:

http://wdc.custhelp.com/app/answers/detail/a_id/940

All the test came back positive.

Somehow I feel that I should be able to assign the drive a letter (Like your C drive D drive etc), however when you plug the drive in this usually happens automatically.

A friend told me to format the drive and hope for the best. However I do have some data that I would like to access before formatting the drive. Therefore I do not want to give up the data before I’ve tried everything that I can. I have some data recovery software however I have been unsuccessful in retrieving the data. But that is mainly due to my lack of knowledge of this software.

I would really like to receive some tips on how to resolve this problem. All I want is the drive to be working like a normal internal drive.

Thanks in advance.

Best regards,

Koen.

  apparaatbeheer.png

  scan drive.png

Have you check on the disk management?

How is the drive showing there?

Make sure that the drive is online on the disk management

1 Like

Those yellow triangle with exclamation point in device manager, update them please.

1 Like

@ Ragdexx This is how it shows up in my disk management (it doesn’t). It just shows my other drives.

@trythesefirst I’ve updated them with no effect.

Thank you for your response but no solution yet. :cry:

Can you try to upload again the picture about the drive in disk management. Did you already tried to connect the drive in a different computer?

1 Like

@trythesefirst I can upload the picture again when I am home. However it doesn’t show the WD drive just my other (working) drives. I haven’t tried connecting the drive to a different pc, I don’t have one near. I will try that soon and get back. However I assume it won’t work either.

Thank you for your response.

Also try to upload a picture of the drive itself