Before I begin I should mention I am a full time computer technician.
Western Digital has been my go to for both hard drive and External Hard drive and has been my primary recommendation for customers for years. I have a computer with 3 western digital drives inside.

But my recent experience is going to likely change that.

I got this external hard drive from newegg and I loved it. It worked great and I had no issues with it until recently. I had it maxed out storage wise (1TB) and I was transferring the data from the elements drive to another 2TB WD external HD. Right in the middle of the transfer I got an error message about the transfer being interrupted. So I went to restart the transfer and the Elements external HDD was no longer being seen by window explorer. I unconnected the drive and reconnected it and my computer made the full indications that a device was being connected. But still the drive was not being seen by windows explorer. I check device manager and the Elements HD is being seen but under disk management I couldn’t initialize it. When ever I would unplug the drive and error message would come up saying “please mount drive” but it only came when I unplugged the drive.
Anyways I spent about 3 days troubleshooting why the Elements external was not being seen.

After about a week trouble shooting and I went to check if I was under warranty and I was a few months out of the warranty period.
Knowing the external was no longer under warranty I decided to undergo some other measures to fix it.
I removed the drive from the caddy and attempted to hard wire it into my computer but was unable to because the connections. I replaced the circuit board, and I even attempted to freeze the drive and still it did not work. Nothing I did changed the status of the drive. After spending 2 months trying to fix the drive I am in the same position. At this point I don’t even want the drive but I need the data that is on it. A clean room data recovery is beginning to look like my only option.

I never did anything with this external. It sat on my desk in my house and was never moved. It was never moved. Never dropped nothing that should have ever caused it to fail to this measure.

I’m lost and for the most part lost faith in WD products.
Is there anything you can do to help me?

As a full time computer technician you should have known better than to trust important data to only one drive. 


That was the point of the transfer I was doing when the drive **bleep** out. [Deleted]

It really sounds like you may have hit a bad sector with some corrupted data on it.  Corruption is usually the case if you can see the drive in disk management but not in Computer.  Did you try another usb cable, another port, another computer, as well?

If the drive spins fine, you may want to try some partition recovery software on the drive. 

I have tried 3 different cables and every port in my computer. I can’t do any form of data recovery because any data recovery software does not see my external.

You might also try accessing the drive by booting from a Linux Live CD. Sometimes that will recognize the drive and allow you to copy the files.


I agree with Joe_S, try to read (backup) the entire drive on a Linux system before attempting any irreversible action. Take a look into  Image Your Hard Drive using dd guide.

Hopefully, you can restore your data!

booting to a linix Cd was one of the firs things i tried.

if it adds any context the light on the front is always flashing,

Great just got off the phone with “WD Support” and they basically just told me where I could spend $2000 to recove my data.  NEVER BUYING WESTER DIGIATIAL AGAIN.

As a computer tech apparently you haven’t learned to never trust important data to just one drive internal or external regardless of the maker. A backup means 2 copies on different drives. I doubt Seagate or other drive makers do free data recovery on bad drives.