WD Elements 1TB USB 2.0 - Unrecognizable by USB port

I go a WD Elements 1TB for a few years now and I never had any problem. Today I plugged it in my PC and it didn’t open. As I searched for the problem, I found that the external hard drive is not recognized in any PC that I own. It usually say “Device not recognized” and it doesn’t even appear on device management.

I tried several solutions to the problem and none worked.
Please help me because I have to recover the very important data.



Please try some basic troubleshooting.

1- Connect the power adapter to the wall directly.

2- If the computer is a desktop, connect it on the back USB port (directly to the PC, not through a hub).

3- Make sure you hear the connection sound windows makes when recognizes a USB device.

4- Go to "Disk Management” to verify if the drive shows up there.

If the drive shows up in disk management but it is not seen on Computer, then it means the partition is corrupted and you will have to format it in order to use it again. Please note that formatting the drive will delete all data stored on it.

You may use a data recovery software in order to recover the data on your drive.

Try booting from a Linux rescue CD. I have had good results recovering data in this way when Windows could not access the drive. Here are a couple of possibilities:



I favor the second of these, booting to Linux in the default Gparted Magic configuration. The whole disk is loaded with easy to use menus, and tons of useful utilities.