Trouble playing MP4 video files!

Hi, ok so I am using the latest WDTV SMP.

Having alot of trouble playing MP4 video files.  Plays for 20sec and then freezes. Exit out and then every video file including MKV files give an unsupported file error. Have tried factory reset, factory restart, rollback firmware and even customer support over the phone. Checked alot of forums and it seems many users are experiencing my exact same issue with the WDTV SMP. Cant seem to find a fix anywhere though. Guess you would say ive given up on WD providing a firmware that actually works perfectly.

In regards to rolling back the firmware, ive been unable to test firmware 1.03.10 as the download file from another  forum is not recognized by the unit. Strange as had no problems rolling back to 1.04 and 1.05 from 1.06 (Latest Firmware) but unable to with 1.03.

Lastly, these files in question work perfectly on 2 of my WDTV LIVE HUB`s and my PC so theres no problem with the files.

If anyone can help me that would be fantastic :slight_smile:

Update: Ive tried playing these files via network share and direct USB. Both have unfortunately failed :frowning: Again both these methods play the files fine via the LIVE HUB. And before anyone says “just convert to MKV”…When youve got 3TB of Movie files in which most are MP4 files, id have to sadly decline that suggestion.                               

1 Like

Puh, sounds weired. Just one question. The only files I had issues with so far were encoded with VC-1. How about yours?

Hi, I’m not sure about the encoding. I will check a few files and then get back to u. Either way, these files all play fine on my pc as well as my live hub so they should play fine on my live smp. Only fix I’ve found so far is to convert the files to mkv which I know would work but as stated above, there’s “alot” of files :frowning:

I saw this comment posted at another site…

“The WD Support Section have been most helpful and I understand the problem is if the video has a bit rate greater than 15mbs. I have resolved the problem by convert the MP4 file to MKV or M4V both of which play fine. …”

Don’t Even consider the conversion. Its happening with MKV files as well… In any case the same codecs should work in this newest model WD TV live as the previous models. Honestly it’s a bit fustrating having to wait for a fix… I hate to think i have to consider using a different brand media player after 5 years of satisfying service.:robotmad:

Yeah, I don’t think I would ever go down the path of conversion. It would take way to much time and as I said earlier I really shouldn’t have to if the files are perfect. Unfortunately I think your right and I’m just going to have to wait for a firmware update that fixes the issue. That’s if it ever comes along :frowning:

To rollback to 1.03.10 - NOT advised by Western Digital as it could lead to problems. - unzip the files and edit the ver file with notepad, change the version from 1.03.10 to say 2.03.10 and save. This edit fools the player into accepting a rollback.

To convert an mp4 to mkv does not take much time in fact just seconds or minutes. An mkv is just a wrapper with the mp4 inside it. Sometimes files which have problems play better when in an mkv - sometimes they don’t. To convert use mkvmerge. (free)

1 Like

Thanks for the advice in regards to rolling back the firmware. The rollback to version 1.03.10 worked fine but sadly does not fix the issue of MP4 video files not playing on the SMP. So to confirm for everyone having the same issue, dont bother rolling back to firmware 1.05.18, 1.04.12 or 1.03.10 as neither of them will fix this issue. Ive heard rolling back to the earlier 1.02 firmware works fine but this firmware is unable to be downloaded anywhere.

If anyone could provide a link to download the original firmware that would be great!

I will convert a couple of files to see if that works and will repost with my results. Thank you for everyones help so far :slight_smile:

Will still need to post my results later today in regards to converting a couple of files but for now here is the video information for 1 of the MP4 files that is currently not working correctly on my WDTV SMP.


ID : 1

Format : AVC

Format/Info : Advanced Video Codec

Format profile : High@L4.1

Format settings, CABAC : Yes

Format settings, ReFrames : 4 frames

Codec ID : avc1

Codec ID/Info : Advanced Video Coding

Duration : 1h 33mn

Bit rate : 2 499 Kbps

Maximum bit rate : 20.0 Mbps

Width : 1 280 pixels

Height : 688 pixels

Display aspect ratio : 1.860

Frame rate mode : Constant

Frame rate : 23.976 fps

Color space : YUV

Chroma subsampling : 4:2:0

Bit depth6 : 8 bits

Scan type : Progressive

Bits/(Pixel*Frame) : 0.118

Stream size : 1.63 GiB (86%)

Writing library : x264 core 104 r1677 19df41a

Encoding settings : cabac=1 / ref=4 / deblock=1:0:0 / analyse=0x3:0x113 / me=hex / subme=6 / psy=1 / psy_rd=1.00:0.00 / mixed_ref=1 / me_range=16 / chroma_me=1 / trellis=1 / 8x8dct=1 / cqm=0 / deadzone=21,11 / fast_pskip=1 / chroma_qp_offset=-2 / threads=3 / sliced_threads=0 / nr=0 / decimate=1 / interlaced=0 / constrained_intra=0 / bframes=3 / b_pyramid=0 / b_adapt=1 / b_bias=0 / direct=1 / weightb=1 / open_gop=0 / weightp=2 / keyint=250 / keyint_min=23 / scenecut=40 / intra_refresh=0 / rc_lookahead=40 / rc=2pass / mbtree=1 / bitrate=2499 / ratetol=1.0 / qcomp=0.60 / qpmin=10 / qpmax=51 / qpstep=4 / cplxblur=20.0 / qblur=0.5 / ip_ratio=1.40 / aq=1:1.00

Encoded date : UTC 2011-02-16 11:08:12

Tagged date : UTC 2011-02-16 23:30:54


ID : 2

Format : AAC

Format/Info : Advanced Audio Codec

Format profile : LC

Codec ID : 40

Duration : 1h 33mn

Bit rate mode : Variable

Bit rate : 401 Kbps

Maximum bit rate : 419 Kbps

Channel(s) : 6 channels

Channel positions : Front: L C R, Side: L R, LFE

Sampling rate : 48.0 KHz

Compression mode : Lossy

Stream size : 268 MiB (14%)

Encoded date : UTC 2011-02-16 23:29:40

Tagged date : UTC 2011-02-16 23:30:54

Can I ask where did you get the mp4 files from?  Mp4’s downloaded from the Australian ABC iView website will not play on the WDTV Live SMP.  They need to be remuxed.  This post shows how to do it.

It only takes a few seconds to do. 

All of my movie files have been downloaded via uTorrent. So none of the video files are copy protected.

Are you tring to view these via a wireless connect, or are these videos on a HD connected to the player?  If the answer is “wireless” I would guess you do not have a robust wireless connection and should be wired or the files to view ought to be on a HD connected to the Live player.

The files are located on 2 hard drives. The first being a WD My Book Live hard drive and the Second being a WD Elements hard drive. The My Book Live is connected via Ethernet to one SMP and the Elements is connected directly to my second SMP via USB. I never stream wirelessly as I find it lags to much when trying to view larger HD files.

Hmm, and you are having trouble with both drives playing the mp4s?  I presume these are DVD movies that are mp4s, and not simple mp4s from various websites like YouTube, or whatever?

All I can guess is that the mp4 files are not compatible with the WD.  I have no problems with the simple mp4s I convert from the YouTube flash videos, etc.  None of my movies are from any “torrent” sites; I make my own ISO and MKV files from my own discs and they all work fine on the WD Live.

Yes all MP4 files are DVD/BLURAY movies converted to MP4. I to have many movies that are of MKV and ISO format. Those formats work great on the SMP. My only issue is with MP4 and considering that this unit is meant to support MP4 video files, I really shouldn’t be having this issue…

I would definitely like to hear from someone that has a WDTV SMP that is able to play MP4 files fine. And If they do play fine then what firmware are you running?

Oh sorry, yes the movies do not play on either drive. I have even tried playing movies from 2 separate WD Elements Portable USB hard drives to no prevail :frowning:

As has said before you have downloaded from torrent sites so it may be that these are not encoded entirely to ‘standard’ plus its not considered ‘good’ form’ to double post.

What version of FW are your hubs using?

Hi, my Live Hubs are using the current 3.01.19 Firmware but the Hubs are fine.

My issue to with the latest  WD TV Streaming Media Player. At present im using the latest 1.06.04 Firmware but have tried rolling back to 2 previous firmwares with no luck. The only Firmware I havent tried rolling back to as yet is the 1.03 firmware. For some reason the WDTV SMP wont recognize it.

I cant think of anything else that may be causing the MP4 files not to play besides a firmware issue.

Its definetly not the unit itself as I own 2 SMP units and both do the same thing.

Yup…same issue here.

Hoping for it to be fixed in next Firmware update! :confounded: