Mp4 files

Hi there

I’ve been reading on the forum about mp4 files and it seems there are some mp4 files that can play and others that can’t. I’ve only had the hub a week and last week I played an mp4 file and it worked. Yesterday I upgraded to 2.07.17 and tried playing a different mp4 file and didn’t work.

The message is a bit premature and I should probably check whether the first mp4 file I played still works to determine whether its the firmware update or the mp4 file itself, but I thought I’d check here to see if the 2.07.17 is known to give issues with mp4. I haven’t seen anything directly relating to that software upgrade.

I have played MANY mp4 files on my WDTV Live Hub Firmware 2.07.17  (On the Internal HDD)

And have Not encounted ANY that wont play, stutter, play fast etc…

Have played many of my older HD files that were .MOV and ‘Transcoded’ them to .MP4 (Using Quicktime Pro) and these play perfectly as well.

All good, Fingers X  of course :smiley:

Thanks Joey

Wonder why this particular file doesnt play. I’ll test a few other files when I get home and post the results. I see you mentioned that you play off the internal harddrive. Will there be any difference between playing off internal and playing off external? Should I try copy the mp4 to internal and see what happens? Or am I reading into your message too much :slight_smile:


Will there be any difference between playing off internal and playing off external? Should I try copy the mp4 to internal and see what happens? Or am I reading into your message too much :slight_smile:

I dont know if there will be any difference, but i know from reading the forums certain media types ‘streamed’ can cause issues.

I was just stating how i watch my media … meaning, i dont stream it … (never have, i live in an small apartment)  

Once in a while I get a file that won’t play properly. If I run that file through a conversion program, as in converting mp4 to mp4, I get something that will play.

No, it should not matter where the file is coming from, whether internal or external drive, or NAS, or Network Share.

Turns out it was the specific file I was trying to play… Plays on my laptop, but not on the tv live hub. Not a trainsmash, my wd just doesn’t seem to like topgear all that much :slight_smile:

I have had my WD Live Hub over a Year now & Love Love Love it & how it makes my life easier.  That said, I too have problems with Mp4 files & there is no ryme or reason as to why it plays sometimes & not play when you need it to.

It seems to always mess up when we have friends over… I know right!  but plays fine late night… 

I hope WD has a fix for why this happens soon as I convert most of my DVD’s to Mp4 files so that I do not lose as much quality.

I have just under 6TB of movies & shows on my server & Mp4 seems the best & smaller files without losing the BlueRay quality.

If someone has a link or a solution to this please post in the thread!  


Gandalff :manhappy:

Gandalff wrote:

If someone has a link or a solution to this please post in the thread!  




Gandalff :manhappy:

Heck, this thread was so old it’s not really relevant anymore.   Most of the posts above were already solved.

If you’re trying to preserve Bluray quality, then dont conver them at all.   Keep them in the original TS files.

Ok tried a few more things & found this to have worked.

Unplug all cables going into the back of the WD device and let sit for at least 30 -45 seconds.  Plug back in all wires leaving the power cord as the last wire being pluged in.

Allow WD device to find & link back up to the network, get it’s IP Adress renewed & allow time for any files it may have found to update.

Find the movie/show you were wanting to watch & play.  Mp4 files that I had tried to play before first post now plays fine & in 1080P full screen.

Note:  I had attempted to rename file several different times but went back to original file name & mp4 after doing the steps above & Every mp4 1080p file that would not play before now plays… 

WD Live Hub Rocks!!

come on, body has even mentioned codec’s this is really basic

MP4 is a container, so what codec’s are used inside it for audio, what codecs are used inside for video

that’s what really makes a file playable or not

you need to run media info

on the non-playable file

and then on a playable file and compare the codecs and other paramenters used

regardless you’re going to need to transcode to something useable

Yea as it was stated CODECS is what really matters - translates the file format format to sound/video, if you will.

On that – WD used to run a codec request site when I bought my WD and nothing now… at least that I can find. More often than not I wait for the Firmware updates FOR and only for the codec support that gets added.

Below is what a MKV file CAN look like, since MKV is a container or almost ANY VIDEO and AUDIO CODECs:

PLEASE NOTE: This is from “MEDIA INFO” ( ), and WD HUB does not yes support the profile below “High 10@L4.1” – So media info showed me my problem.

== VIDEO ==

ID                                       : 1
Format                                   : AVC
Format/Info                              : Advanced Video Codec
Format profile                           : High 10@L4.1
Format settings, CABAC                   : Yes
Format settings, ReFrames                : 9 frames
Codec ID                                 : V_MPEG4/ISO/AVC
Duration                                 : 23mn 39s
Width                                    : 1 280 pixels
Height                                   : 720 pixels
Display aspect ratio                     : 16:9
Frame rate mode                          : Constant
Frame rate                               : 23.976 fps
Color space                              : YUV
Chroma subsampling                       : 4:2:0
Bit depth                                : 10 bits
Scan type                                : Progressive
Title                                    : H.264 720p HDTV
Writing library                          : x264 core 128 r2216+698 b3c1019
Encoding settings                        : cabac=1 / ref=10 / deblock=1:-1:-1 / analyse=0x3:0x133 / me=umh / subme=10 / psy=1 / fade_compensate=1.05 / psy_rd=0.70:0.08 / mixed_ref=1 / me_range=24 / chroma_me=1 / trellis=2 / 8x8dct=1 / cqm=0 / deadzone=21,11 / fast_pskip=0 / chroma_qp_offset=-3 / threads=18 / lookahead_threads=4 / sliced_threads=0 / nr=0 / decimate=0 / interlaced=0 / bluray_compat=0 / constrained_intra=0 / fgo=0 / bframes=8 / b_pyramid=1 / b_adapt=2 / b_bias=0 / direct=3 / weightb=1 / open_gop=0 / weightp=2 / keyint=240 / keyint_min=24 / scenecut=40 / intra_refresh=0 / rc_lookahead=120 / rc=crf / mbtree=1 / crf=17.0000 / qcomp=0.80 / qpmin=0 / qpmax=81 / qpstep=4 / ip_ratio=1.30 / aq=1:0.85
Language                                 : Japanese
Default                                  : Yes
Forced                                   : No
Color primaries                          : BT.709
Transfer characteristics                 : BT.709
Matrix coefficients                      : BT.709

== AUDIO ==

ID                                       : 2
Format                                   : AAC
Format/Info                              : Advanced Audio Codec
Format profile                           : LC
Codec ID                                 : A_AAC
Duration                                 : 23mn 39s
Channel(s)                               : 2 channels
Channel positions                        : Front: L R
Sampling rate                            : 48.0 KHz
Compression mode                         : Lossy
Title                                    : AAC LC 2.0
Language                                 : Japanese
Default                                  : Yes
Forced                                   : No

== START – Another Community member wrote: The codecs are built into the Sigma chip – any codecs the chip can’t decode when it leaves the factory, support for them can’t be added at a later date, by either Sigma or WD. Even within the codec itself, nothing can be changed – h.264 supports up to L4.1… support for L5 and L5.1 can’t be added – a new chip would be required for that.

== END - Another Community member wrote

I do agree with what the other member wrote, but at the same time their are things the current hardware has done that they have disabled (in past) and later released as a firmware update… so it is hit and miss if a F/W update will fix it. However, if its past the h.264 L4.1 @ 8 bit… it will be a stretch.

every mp4 video file i have video works fine but theres no audio at all.

and its annoying i download BDrips nowdays by YIFY and there all in .mp4 and well i havent tried these /mp4s yet but all other mp4 files audio doesnt work bu video is fine.

is that just the audio codec not playable by the hub?



Every *.mp4 that i have with 2 Channel AAC Audio plays fine on my WDTV Live Hub


If ever i have any problems, than i use either AviDemux or XviD4PSP encoders to re-encode only the “Audio”


ie. Open the *.mp4 and under “Video Settings” select “Copy” and under “Audio Settings” select what you want eg. AC3, MP3 etc


The above Only re-encoded’s the “Audio” … (and does not touch the video)


P.S. the names of these programs are mis-leading … since they work fine with HD Mkv and Mp4



ok thank you whats the recommended audio option to encode to?